summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-05-16 18:08:27 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-05-16 20:09:52 +0200
commitd1ed1d7560d454e271f682728a3dcaa76032077f (patch)
treedce2a1822cfa125e520b4a20f0611f65e76705ef /gnu/packages/linux.scm
parent1f595f3cf46943f31b5cc96e5fd16c8264d0db52 (diff)
downloadpatches-d1ed1d7560d454e271f682728a3dcaa76032077f.tar
patches-d1ed1d7560d454e271f682728a3dcaa76032077f.tar.gz
gnu: multipath-tools: Fetch with git.
* gnu/packages/linux.scm (multipath-tools)[source]: Change to GIT-FETCH.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index bfee4374bd..793036a3ff 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -4184,13 +4184,14 @@ arrays when needed.")
(name "multipath-tools")
(version "0.8.3")
(source (origin
- (method url-fetch)
- (uri (string-append "https://git.opensvc.com/?p=multipath-tools/"
- ".git;a=snapshot;h=" version ";sf=tgz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.opensvc.com/multipath-tools/.git")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1c6ay97wlfv1fl0y8hcfpxhkps14hlnw9gzmj7884micsp7pa9yv"))
+ "02kdbk3gv3fx5dg445scz3l4lg0sznlv037qkjgpw9xkw4l50cfd"))
(modules '((guix build utils)))
(snippet
'(begin