summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-08-16 21:35:29 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-08-16 22:21:53 +0200
commit1dfb14d2f7734e14f1644c609a35d3dc88830501 (patch)
treec3b76925a3c862310355407fef03257fa24b64c2 /gnu/packages/linux.scm
parent76c888cb940f7817b8c6c570a760fdf5f0c176cc (diff)
downloadpatches-1dfb14d2f7734e14f1644c609a35d3dc88830501.tar
patches-1dfb14d2f7734e14f1644c609a35d3dc88830501.tar.gz
gnu: btrfs-progs: Update to 4.17.1.
* gnu/packages/linux.scm (btrfs-progs): Update to 4.17.1. [source]: Remove patch. [native-inputs]: Add python. * gnu/packages/patches/btrfs-progs-e-value-block.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 02fdd816a0..d952c34614 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -3240,7 +3240,7 @@ and copy/paste text in the console and in xterm.")
(define-public btrfs-progs
(package
(name "btrfs-progs")
- (version "4.15.1")
+ (version "4.17.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://kernel.org/linux/kernel/"
@@ -3248,8 +3248,7 @@ and copy/paste text in the console and in xterm.")
"btrfs-progs-v" version ".tar.xz"))
(sha256
(base32
- "15izak6jg6pqr6ha9447cdrdj9k6kfiarvwlrj53cpvrsv02l437"))
- (patches (search-patches "btrfs-progs-e-value-block.patch"))))
+ "0x6d53fbrcmzvhv461575fzsv3373427p4srz646w2wcagqk82xz"))))
(build-system gnu-build-system)
(outputs '("out"
"static")) ; static versions of the binaries in "out"
@@ -3285,6 +3284,7 @@ and copy/paste text in the console and in xterm.")
("zstd" ,zstd)))
(native-inputs `(("pkg-config" ,pkg-config)
("asciidoc" ,asciidoc)
+ ("python" ,python)
("xmlto" ,xmlto)
;; For building documentation.
("libxml2" ,libxml2)