summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-06-11 10:27:09 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-06-11 10:27:09 +0200
commit58bf51b4c0771fb6cfcf22be84d734096e7b11e0 (patch)
tree69c22625468b10e43fd37e7c5ddc420a1de6ab55 /gnu/packages/linux.scm
parent69ecd666d73ebc5ee7a0be54f4e24f000d1d7e31 (diff)
parentbf3005346e6538aba6d077c887f688779b94b274 (diff)
downloadpatches-58bf51b4c0771fb6cfcf22be84d734096e7b11e0.tar
patches-58bf51b4c0771fb6cfcf22be84d734096e7b11e0.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm46
1 files changed, 17 insertions, 29 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 5401b1ad97..b6887349fa 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -430,8 +430,8 @@ for ARCH and optionally VARIANT, or #f if there is no such configuration."
It has been modified to remove all non-free binary blobs.")
(license license:gpl2)))
-(define %linux-libre-version "5.1.7")
-(define %linux-libre-hash "0hr4sbapdpgdkb6xg1f7bpc31242yiqdvy5sfpymsrzfslr8vwy1")
+(define %linux-libre-version "5.1.8")
+(define %linux-libre-hash "1vkirlz9vsvym8fdbvj308n3hj8f9j8n9m267x0dhlgbmig570j2")
(define %linux-libre-5.1-patches
(list %boot-logo-patch
@@ -448,8 +448,8 @@ It has been modified to remove all non-free binary blobs.")
(make-linux-libre-headers %linux-libre-version
%linux-libre-hash))
-(define %linux-libre-4.19-version "4.19.48")
-(define %linux-libre-4.19-hash "04jwwzc9wbhx33i4bhm3vbs52vxlb8kjdmfjpfild94xbk8m2wy4")
+(define %linux-libre-4.19-version "4.19.49")
+(define %linux-libre-4.19-hash "0dxmm8190h0g5indj3sqfipkji10y3icr8xnf7bbz7086nkkrcvz")
(define %linux-libre-4.19-patches
(list %boot-logo-patch
@@ -466,22 +466,8 @@ It has been modified to remove all non-free binary blobs.")
(make-linux-libre-headers %linux-libre-4.19-version
%linux-libre-4.19-hash))
-(define %linux-libre-4.15-version "4.15.18")
-(define %linux-libre-4.15-hash "0f0s4drx888ydlwjcm9qcxqian4850yiv2vamyw9bbjf83frwxyw")
-
-(define-public linux-libre-4.15
- (make-linux-libre %linux-libre-4.15-version
- %linux-libre-4.15-hash
- '("x86_64-linux" "i686-linux" "armhf-linux")
- #:configuration-file kernel-config))
-
-(define-public linux-libre-headers-4.15
- (make-linux-libre-headers %linux-libre-4.15-version
- %linux-libre-4.15-hash))
-
-
-(define %linux-libre-4.14-version "4.14.123")
-(define %linux-libre-4.14-hash "185kf576rwhsaq7jqrnmg8r5fh2nh4k8lifxaxwi3amshnwbj2qg")
+(define %linux-libre-4.14-version "4.14.124")
+(define %linux-libre-4.14-hash "0z9iaz1rcm9472rjvcihmq65ygyks07j6kbiqm989r9rb4dw6ghg")
(define-public linux-libre-4.14
(make-linux-libre %linux-libre-4.14-version
@@ -4405,15 +4391,16 @@ developers.")
(define-public radeontop
(package
(name "radeontop")
- (version "1.1")
- (home-page "https://github.com/clbr/radeontop/")
- (source (origin
- (method url-fetch)
- (uri (string-append home-page "archive/v" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "1fv06j5c99imvzkac3j40lgjhr5b2i77fnyffhlvj92bli1fm1c6"))))
+ (version "1.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/clbr/radeontop.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1b1m30r2nfwqkajqw6m01xmfhlq83z1qylyijxg7962mp9x2k0gw"))))
(build-system gnu-build-system)
(arguments
`(#:phases (modify-phases %standard-phases
@@ -4437,6 +4424,7 @@ developers.")
("libpciaccess" ,libpciaccess)
("libxcb" ,libxcb)
("ncurses" ,ncurses)))
+ (home-page "https://github.com/clbr/radeontop/")
(synopsis "Usage monitor for AMD Radeon graphics")
(description "RadeonTop monitors resource consumption on supported AMD
Radeon Graphics Processing Units (GPUs), either in real time as bar graphs on