summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-10-01 11:49:17 +0200
committerLudovic Courtès <ludo@gnu.org>2019-10-01 12:06:00 +0200
commit0cf2b6f2dbcd299f7a4b7a563cf34ae5de154b15 (patch)
tree0b653bb411222fda1d159cb05bee722ff8bac9cc /gnu/packages/linux.scm
parent8d564b8b81b98fec9aac2f5f2d3cb0d1f2ea1416 (diff)
parent717b6ba6aa9ac876b2c2df36096e4579b19ee06c (diff)
downloadpatches-0cf2b6f2dbcd299f7a4b7a563cf34ae5de154b15.tar
patches-0cf2b6f2dbcd299f7a4b7a563cf34ae5de154b15.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm48
1 files changed, 48 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index f517197021..6664620c04 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -36,6 +36,7 @@
;;; Copyright © 2019 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2019 Stefan Stefanović <stefanx2ovic@gmail.com>
;;; Copyright © 2019 Pierre Langlois <pierre.langlois@gmx.com>
+;;; Copyright © 2019 Brice Waegeneire <brice@waegenei.re>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -562,6 +563,13 @@ for ARCH and optionally VARIANT, or #f if there is no such configuration."
(define %default-extra-linux-options
`(;; Some very mild hardening.
("CONFIG_SECURITY_DMESG_RESTRICT" . #t)
+ ;; All kernels should have NAMESPACES options enabled
+ ("CONFIG_NAMESPACES" . #t)
+ ("CONFIG_UTS_NS" . #t)
+ ("CONFIG_IPC_NS" . #t)
+ ("CONFIG_USER_NS" . #t)
+ ("CONFIG_PID_NS" . #t)
+ ("CONFIG_NET_NS" . #t)
;; Modules required for initrd:
("CONFIG_NET_9P" . m)
("CONFIG_NET_9P_VIRTIO" . m)
@@ -5985,3 +5993,43 @@ have to construct the archives directly, without using the archiver.")
(description "inputattach dispatches input events from several device
types and interfaces and translates so that the X server can use them.")
(license license:gpl2+)))
+
+(define-public ell
+ (package
+ (name "ell")
+ (version "0.23")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.kernel.org/pub/scm/libs/ell/ell.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1qhlcwhn0gj877yss2ymx1aczghlddzb5v9mm1dgp2zliii3jy10"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-dbus-tests
+ (lambda _
+ (substitute* '("unit/test-dbus-message-fds.c"
+ "unit/test-dbus-properties.c"
+ "unit/test-dbus.c")
+ (("/usr/bin/dbus-daemon") (which "dbus-daemon")))
+ #t)))))
+ (inputs
+ `(("dbus" ,dbus)
+ ("libtool" ,libtool)))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("pkgconfig" ,pkg-config)
+ ("automake" ,automake)))
+ (home-page "https://01.org/ell")
+ (synopsis "Embedded Linux Library")
+ (description "The Embedded Linux* Library (ELL) provides core, low-level
+functionality for system daemons. It typically has no dependencies other than
+the Linux kernel, C standard library, and libdl (for dynamic linking). While
+ELL is designed to be efficient and compact enough for use on embedded Linux
+platforms, it is not limited to resource-constrained systems.")
+ (license license:lgpl2.1+)))