summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@debian.org>2020-03-25 18:59:25 -0700
committerVagrant Cascadian <vagrant@debian.org>2020-03-25 18:59:25 -0700
commit730a4b10fa49d821e0a89af59485cecf8616cd50 (patch)
tree9569203cdb6e2f19b00fa578ed5f1ecaa3c8d321 /gnu/packages/linux.scm
parent2a57b72251042b819f0822c870c3837f63957d9e (diff)
downloadpatches-730a4b10fa49d821e0a89af59485cecf8616cd50.tar
patches-730a4b10fa49d821e0a89af59485cecf8616cd50.tar.gz
gnu: linux-libre-5.4-source: Add patch to support pinebook pro.
* gnu/packages/patches/linux-libre-support-for-Pinebook-Pro.patch: New file. * gnu/local.mk (dist_patch_DATA): Update accordingly. * gnu/packages/linux (linux-libre-5.4-source): Add patch.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index db8e180dd0..8fec3352f3 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -433,7 +433,11 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(define-public linux-libre-5.4-source
(source-with-patches linux-libre-5.4-pristine-source
(list %boot-logo-patch
- %linux-libre-arm-export-__sync_icache_dcache-patch)))
+ %linux-libre-arm-export-__sync_icache_dcache-patch
+ ;; Pinebook Pro patch from linux-next,
+ ;; can be dropped for linux-libre 5.7
+ (search-patch
+ "linux-libre-support-for-Pinebook-Pro.patch"))))
(define-public linux-libre-4.19-source
(source-with-patches linux-libre-4.19-pristine-source