summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2020-03-12 15:16:58 -0400
committerLeo Famulari <leo@famulari.name>2020-03-13 19:24:30 -0400
commit364a1374ad5e04a91cdc29203f0c8073eede72d4 (patch)
tree8ff76fa796d86f61eb56d087553de16992370fc1 /gnu/packages/linux.scm
parente819fc0285aff217960fe0ef7cd1240959decba1 (diff)
downloadpatches-364a1374ad5e04a91cdc29203f0c8073eede72d4.tar
patches-364a1374ad5e04a91cdc29203f0c8073eede72d4.tar.gz
gnu: BlueZ: Fix CVE-2020-0556.
* gnu/packages/patches/bluez-CVE-2020-0556.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/linux.scm (bluez)[replacement]: New field. (bluez/fixed): New variable.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 7f293a9071..b9787f2ec5 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -3994,6 +3994,7 @@ Bluetooth audio output devices like headphones or loudspeakers.")
(define-public bluez
(package
(name "bluez")
+ (replacement bluez/fixed)
(version "5.52")
(source (origin
(method url-fetch)
@@ -4059,6 +4060,14 @@ Bluetooth audio output devices like headphones or loudspeakers.")
is flexible, efficient and uses a modular implementation.")
(license license:gpl2+)))
+(define bluez/fixed
+ (package
+ (inherit bluez)
+ (source (origin
+ (inherit (package-source bluez))
+ (patches (append (origin-patches (package-source bluez))
+ (search-patches "bluez-CVE-2020-0556.patch")))))))
+
(define-public fuse-exfat
(package
(name "fuse-exfat")