summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-12-02 18:08:21 -0500
committerLeo Famulari <leo@famulari.name>2017-12-20 03:53:52 -0500
commit8bc6956bbd28b749538d113a214a63a93039537f (patch)
treea5897bf7d2a59fdfbd7827c923eb13032f567d56 /gnu/packages/linux.scm
parent09a91adcf8fcb0520bccbb8ae5f0639f002472cd (diff)
downloadpatches-8bc6956bbd28b749538d113a214a63a93039537f.tar
patches-8bc6956bbd28b749538d113a214a63a93039537f.tar.gz
gnu: rng-tools: Update to 6.1.
Rng-tools development appears to have moved to GitHub [0]: "NOTE: The rng-tools project hasn't seen updates in some time, but is still in active use. To facilitate ongoing development, the rng-tools project is moved to here: https://github.com/nhorman/rng-tools" [0] https://sourceforge.net/p/gkernel/wiki/Home/ * gnu/packages/linux.scm (rng-tools): Update to 6.1. [source]: Use new upstream URL and give a descriptive file-name. [arguments]: Add a 'bootstrap' phase. [native-inputs]: Add autoconf, automake, and pkg-config. [inputs]: Add sysfsutils.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm24
1 files changed, 19 insertions, 5 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 7ab2ba84d6..2eb35c92f2 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -3490,16 +3490,30 @@ The following service daemons are also provided:
(define-public rng-tools
(package
(name "rng-tools")
- (version "5")
+ (version "6.1")
(source (origin
(method url-fetch)
- (uri (string-append
- "http://downloads.sourceforge.net/sourceforge/gkernel/"
- "rng-tools-" version ".tar.gz"))
+ (uri (string-append "https://github.com/nhorman/rng-tools/"
+ "archive/v" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "13h7lc8wl9khhvkr0i3bl5j9bapf8anhqis1lcnwxg1vc2v058b0"))))
+ "00ywsknjpc9jd9kfmz2syk9l0xkiiwyx5qhl5zvhhc69v6682i31"))))
(build-system gnu-build-system)
+ (arguments
+ `(;; Avoid using OpenSSL, curl, and libxml2, reducing the closure by 166 MiB.
+ #:configure-flags '("--without-nistbeacon")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'bootstrap
+ (lambda _
+ (zero? (system* "sh" "autogen.sh")))))))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("libsysfs" ,sysfsutils)))
(synopsis "Random number generator daemon")
(description
"Monitor a hardware random number generator, and supply entropy