summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-06-01 22:53:16 +0200
committerLudovic Courtès <ludo@gnu.org>2014-06-01 22:53:16 +0200
commit5a6a3ba43a1830c712e29d09e341e3cf14aea507 (patch)
tree6fca004cfe7b4c3e982dc86bb4b41540680adccb /gnu/packages/linux.scm
parentac52e80b4e02718c9d040062c65f7df24302d226 (diff)
downloadpatches-5a6a3ba43a1830c712e29d09e341e3cf14aea507.tar
patches-5a6a3ba43a1830c712e29d09e341e3cf14aea507.tar.gz
gnu: util-linux: Remove dependency on Perl.
* gnu/packages/linux.scm (util-linux)[source](patches): New field. * gnu/packages/patches/util-linux-perl.patch: New file. * gnu-system.am (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm18
1 files changed, 9 insertions, 9 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 7b46190d79..1690cd8805 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -317,15 +317,15 @@ providing the system administrator with some help in common tasks.")
(package
(name "util-linux")
(version "2.21")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://kernel.org/linux/utils/"
- name "/v" version "/"
- name "-" version ".2" ".tar.xz"))
- (sha256
- (base32
- "1rpgghf7n0zx0cdy8hibr41wvkm2qp1yvd8ab1rxr193l1jmgcir"))))
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kernel.org/linux/utils/"
+ name "/v" version "/"
+ name "-" version ".2" ".tar.xz"))
+ (sha256
+ (base32
+ "1rpgghf7n0zx0cdy8hibr41wvkm2qp1yvd8ab1rxr193l1jmgcir"))
+ (patches (list (search-patch "util-linux-perl.patch")))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags '("--disable-use-tty-group"