summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-12-09 22:31:03 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-12-11 01:14:37 +0100
commitddf31e9a49dffab297946f15cc8625a8984845cb (patch)
tree877649ab10a8287a9170c8990a835c65948d0b90 /gnu/packages/linux.scm
parent3a24bf3a2a7fc89c04dba4c74419e9183e509eb0 (diff)
downloadpatches-ddf31e9a49dffab297946f15cc8625a8984845cb.tar
patches-ddf31e9a49dffab297946f15cc8625a8984845cb.tar.gz
gnu: ALSA: Update to 1.2.1.
* gnu/packages/linux.scm (alsa-lib): Update to 1.2.1.2. [arguments]: New field. (alsa-utils): Update to 1.2.1. (alsa-plugins): Likewise.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm16
1 files changed, 10 insertions, 6 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 8879112357..96e15ebaac 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1534,7 +1534,7 @@ intercept and print the system calls executed by the program.")
(define-public alsa-lib
(package
(name "alsa-lib")
- (version "1.1.9")
+ (version "1.2.1.2")
(source (origin
(method url-fetch)
(uri (string-append
@@ -1542,8 +1542,12 @@ intercept and print the system calls executed by the program.")
version ".tar.bz2"))
(sha256
(base32
- "0jwr9g4yxg9gj6xx0sb2r6wrdl8amrjd19hilkrq4rirynp770s8"))))
+ "0hvrx0ipzqbcx4y1cmr9bgm9niifzkrhsb1ddgzzdwbk6q72d3lm"))))
(build-system gnu-build-system)
+ (arguments
+ '(#:configure-flags (list (string-append "LDFLAGS=-Wl,-rpath="
+ (assoc-ref %outputs "out")
+ "/lib"))))
(home-page "https://www.alsa-project.org/")
(synopsis "The Advanced Linux Sound Architecture libraries")
(description
@@ -1554,14 +1558,14 @@ MIDI functionality to the Linux-based operating system.")
(define-public alsa-utils
(package
(name "alsa-utils")
- (version "1.1.9")
+ (version "1.2.1")
(source (origin
(method url-fetch)
(uri (string-append "ftp://ftp.alsa-project.org/pub/utils/"
name "-" version ".tar.bz2"))
(sha256
(base32
- "0fi11b7r8hg1bdjw74s8sqx8rc4qb310jaj9lsia9labvfyjrpsx"))))
+ "039c19b7091is0czl9jlrfczp7pp1jpdri0vvc4k07gl3skhn48b"))))
(build-system gnu-build-system)
(arguments
;; XXX: Disable man page creation until we have DocBook.
@@ -1608,14 +1612,14 @@ MIDI functionality to the Linux-based operating system.")
(define-public alsa-plugins
(package
(name "alsa-plugins")
- (version "1.1.9")
+ (version "1.2.1")
(source (origin
(method url-fetch)
(uri (string-append "ftp://ftp.alsa-project.org/pub/plugins/"
name "-" version ".tar.bz2"))
(sha256
(base32
- "01zrg0h2jw9dlj9233vjsn916yf4f2s667yry6xsn8d57lq745qn"))))
+ "1nj8cpbi05rb62yzs01c1k7lymdn1ch229b599hbhd0psixdx52d"))))
(build-system gnu-build-system)
;; TODO: Split libavcodec and speex if possible. It looks like they can not
;; be split, there are references to both in files.