summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2020-03-15 21:03:39 -0400
committerLeo Famulari <leo@famulari.name>2020-03-15 21:03:57 -0400
commit8bbbbb39350eb559951972abae2622195393b51e (patch)
tree63ba23cb7a63cb47ce735abe19b5328b5f76e866 /gnu/packages/linux.scm
parentb19f155cf842b5ed6f7ae9c94ef7389e20c10e0f (diff)
downloadpatches-8bbbbb39350eb559951972abae2622195393b51e.tar
patches-8bbbbb39350eb559951972abae2622195393b51e.tar.gz
Revert "gnu: BlueZ: Update to 5.54."
This reverts commit f24aaa81de8c709adfda2e89271c562a5ca8d959. This change caused too many rebuilds for the master branch.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm13
1 files changed, 11 insertions, 2 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index fda7570d89..f1bc5798ab 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -4039,7 +4039,8 @@ Bluetooth audio output devices like headphones or loudspeakers.")
(define-public bluez
(package
(name "bluez")
- (version "5.54")
+ (replacement bluez/fixed)
+ (version "5.53")
(source (origin
(method url-fetch)
(uri (string-append
@@ -4047,7 +4048,7 @@ Bluetooth audio output devices like headphones or loudspeakers.")
version ".tar.xz"))
(sha256
(base32
- "1p2ncvjz6alr9n3l5wvq2arqgc7xjs6dqyar1l9jp0z8cfgapkb8"))))
+ "1g1qg6dz6hl3csrmz75ixr12lwv836hq3ckb259svvrg62l2vaiq"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
@@ -4104,6 +4105,14 @@ Bluetooth audio output devices like headphones or loudspeakers.")
is flexible, efficient and uses a modular implementation.")
(license license:gpl2+)))
+(define bluez/fixed
+ (package
+ (inherit bluez)
+ (source (origin
+ (inherit (package-source bluez))
+ (patches (append (origin-patches (package-source bluez))
+ (search-patches "bluez-CVE-2020-0556.patch")))))))
+
(define-public fuse-exfat
(package
(name "fuse-exfat")