summaryrefslogtreecommitdiff
path: root/gnu/packages/libreoffice.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-05-07 23:11:01 +0200
committerAndreas Enge <andreas@enge.fr>2015-05-07 23:12:28 +0200
commit82741a8a112a472f5249a2412dba7f5b3c26ca88 (patch)
treeff1cc85c424a48b1b4d0d0f603543fc757ba4a94 /gnu/packages/libreoffice.scm
parent1d59b83b27a65800ac292fd25152ee6bf4f40fe8 (diff)
downloadpatches-82741a8a112a472f5249a2412dba7f5b3c26ca88.tar
patches-82741a8a112a472f5249a2412dba7f5b3c26ca88.tar.gz
gnu: Add libwps.
* gnu/packages/libreoffice.scm (libwps): New variable.
Diffstat (limited to 'gnu/packages/libreoffice.scm')
-rw-r--r--gnu/packages/libreoffice.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index c058e03a0d..17f4a0ca01 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -480,3 +480,31 @@ text documents, vector drawings, presentations and spreadsheets.")
text documents (MacWrite, ClarisWorks, ... ) and for some graphics and
spreadsheet documents.")
(license (list mpl2.0 lgpl2.1+)))) ; dual license
+
+(define-public libwps
+ (package
+ (name "libwps")
+ (version "0.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/" name "/" name "/"
+ name "-" version ".tar.xz"))
+ (sha256 (base32
+ "14wfhw1ahavhx4hrdzc4hdwxjlffrm939kswf2x1250jnmyjlb5v"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("doxygen" ,doxygen)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("boost" ,boost)
+ ("librevenge" ,librevenge)
+ ("zlib" ,zlib)))
+ (arguments
+ ;; avoid triggering configure errors by simple inclusion of boost headers
+ `(#:configure-flags '("--disable-werror")))
+ (home-page "http://libwps.sourceforge.net/")
+ (synopsis "Import library for Microsoft Works text documents")
+ (description "Libwps is a library for importing files in the Microsoft
+Works word processor file format.")
+ (license (list mpl2.0 lgpl2.1+)))) ; dual license