summaryrefslogtreecommitdiff
path: root/gnu/packages/libreoffice.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-05-07 22:35:13 +0200
committerAndreas Enge <andreas@enge.fr>2015-05-07 23:12:28 +0200
commit74a63b118b4069635077a234819430e65c591140 (patch)
tree53f84bf2c49ef8192fe6e261ebebe4d3af686f18 /gnu/packages/libreoffice.scm
parentcf2abac8ec07ca421393df755211779b60739ae6 (diff)
downloadpatches-74a63b118b4069635077a234819430e65c591140.tar
patches-74a63b118b4069635077a234819430e65c591140.tar.gz
gnu: Add libodfgen.
* gnu/packages/libreoffice.scm (libodfgen): New variable.
Diffstat (limited to 'gnu/packages/libreoffice.scm')
-rw-r--r--gnu/packages/libreoffice.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index fb308603c6..2db4a83893 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -421,3 +421,33 @@ created by PageMaker version 6.x and 7.")
(description "Libvisio is a library that parses the file format of
Microsoft Visio documents of all versions.")
(license mpl2.0)))
+
+(define-public libodfgen
+ (package
+ (name "libodfgen")
+ (version "0.1.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://dev-www.libreoffice.org/src/"
+ name "-" version ".tar.bz2"))
+ (sha256 (base32
+ "074qsav86ixwi9zm1f77g9vxdf1ihm6n930vxjg8q3lwzd8g7lb6"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("doxygen" ,doxygen)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("boost" ,boost)
+ ("librevenge" ,librevenge)
+ ("zlib" ,zlib)))
+ (arguments
+ ;; avoid triggering configure errors by simple inclusion of boost headers
+ `(#:configure-flags '("--disable-werror")))
+ (home-page "http://sourceforge.net/p/libwpd/wiki/libodfgen/")
+ (synopsis "ODF (Open Document Format) library")
+ (description "Libodfgen is a library for generating documents in the
+Open Document Format (ODF). It provides generator implementations for all
+document interfaces supported by librevenge:
+text documents, vector drawings, presentations and spreadsheets.")
+ (license (list mpl2.0 lgpl2.1+)))) ; dual license