summaryrefslogtreecommitdiff
path: root/gnu/packages/libreoffice.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-09-04 13:32:54 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-09-09 17:59:35 +0200
commitf6f8645cc9337309eeae21e0d036a3167c4a85bc (patch)
treea941e052a49870dcf15ca998b4d7e8033f65a532 /gnu/packages/libreoffice.scm
parent436969904cef613b2fa0809cfa453d3db7e18d52 (diff)
downloadpatches-f6f8645cc9337309eeae21e0d036a3167c4a85bc.tar
patches-f6f8645cc9337309eeae21e0d036a3167c4a85bc.tar.gz
gnu: libcmis: Fix FTBFS with Boost >= 1.68.0.
* gnu/packages/libreoffice.scm (libcmis)[arguments]: Add phase to substitute header file name.
Diffstat (limited to 'gnu/packages/libreoffice.scm')
-rw-r--r--gnu/packages/libreoffice.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index 3dc7a4bbf2..690fa80512 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -316,7 +316,16 @@ working with graphics in the WPG (WordPerfect Graphics) format.")
;; During configure, the boost headers are found, but linking
;; fails without the following flag.
(string-append "--with-boost="
- (assoc-ref %build-inputs "boost")))))
+ (assoc-ref %build-inputs "boost")))
+ #:phases (modify-phases %standard-phases
+ (add-before 'build 'fix-boost-include
+ (lambda _
+ ;; This library moved in Boost and the compatibility
+ ;; redirect is no longer available since version 1.68.0.
+ (substitute* "src/libcmis/xml-utils.cxx"
+ (("boost/uuid/sha1.hpp")
+ "boost/uuid/detail/sha1.hpp"))
+ #t)))))
(home-page "https://github.com/tdf/libcmis")
(synopsis "CMIS client library")
(description "LibCMIS is a C++ client library for the CMIS interface. It