summaryrefslogtreecommitdiff
path: root/gnu/packages/libreoffice.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-07-22 18:58:48 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-07-22 18:58:48 +0200
commitccad0e4d6973da7af8badfb7125f35f7e51eb2d7 (patch)
tree15ff9da1c1c03b088d0ad9240f2c1878f5da5802 /gnu/packages/libreoffice.scm
parentd478cc043557ca3fcd5fced87d2e2c8e246eff03 (diff)
parent26986544469ef290885f5f8d71006751e9e8daf8 (diff)
downloadpatches-ccad0e4d6973da7af8badfb7125f35f7e51eb2d7.tar
patches-ccad0e4d6973da7af8badfb7125f35f7e51eb2d7.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/libreoffice.scm')
-rw-r--r--gnu/packages/libreoffice.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index 7fc2c1461b..8a5d5724a8 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2018 Jonathan Brielmaier <jonathan.brielmaier@web.de>
+;;; Copyright © 2019 Chris Marusich <cmmarusich@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -53,6 +54,7 @@
#:use-module (gnu packages documentation)
#:use-module (gnu packages flex)
#:use-module (gnu packages fontutils)
+ #:use-module (gnu packages freedesktop)
#:use-module (gnu packages ghostscript)
#:use-module (gnu packages gl)
#:use-module (gnu packages glib)
@@ -1051,6 +1053,7 @@ converting QuarkXPress file format. It supports versions 3.1 to 4.1.")
("unixodbc" ,unixodbc)
("unzip" ,unzip)
("vigra" ,vigra)
+ ("xdg-utils" ,xdg-utils)
("xmlsec" ,xmlsec-nss)
("zip" ,zip)))
(arguments
@@ -1083,6 +1086,13 @@ converting QuarkXPress file format. It supports versions 3.1 to 4.1.")
(assoc-ref inputs "gpgme")
"/include/gpgme++")))
+ ;; /usr/bin/xdg-open doesn't exist on Guix System.
+ (substitute* '("shell/source/unix/exec/shellexec.cxx"
+ "shell/source/unix/misc/senddoc.sh")
+ (("/usr/bin/xdg-open")
+ (string-append (assoc-ref inputs "xdg-utils")
+ "/bin/xdg-open")))
+
#t))
(add-after 'install 'bin-and-desktop-install
;; Create 'soffice' and 'libreoffice' symlinks to the executable