summaryrefslogtreecommitdiff
path: root/gnu/packages/libftdi.scm
diff options
context:
space:
mode:
authorManolis Ragkousis <manolis837@gmail.com>2014-07-23 23:59:04 +0000
committerLudovic Courtès <ludo@gnu.org>2014-07-24 09:42:32 +0200
commit77362186831b8c07e33b2e8ef0b4c09a446893a4 (patch)
tree9c37603e6c3eec20bae31aeec9fa4da13e7d5b23 /gnu/packages/libftdi.scm
parent9fd571a29201b90d750e3e7b4be4842ae6cc59ca (diff)
downloadpatches-77362186831b8c07e33b2e8ef0b4c09a446893a4.tar
patches-77362186831b8c07e33b2e8ef0b4c09a446893a4.tar.gz
gnu: Add libftdi.
* gnu/packages/libftdi.scm: New file * gnu-system.am (GNU_SYSTEM_MODULES): Add libftdi.scm Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/libftdi.scm')
-rw-r--r--gnu/packages/libftdi.scm48
1 files changed, 48 insertions, 0 deletions
diff --git a/gnu/packages/libftdi.scm b/gnu/packages/libftdi.scm
new file mode 100644
index 0000000000..6e8100ce29
--- /dev/null
+++ b/gnu/packages/libftdi.scm
@@ -0,0 +1,48 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2014 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages libftdi)
+ #:use-module (guix licenses)
+ #:use-module (guix download)
+ #:use-module (guix packages)
+ #:use-module (gnu packages)
+ #:use-module (gnu packages libusb)
+ #:use-module (guix build-system cmake))
+
+(define-public libftdi
+ (package
+ (name "libftdi")
+ (version "1.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://www.intra2net.com/en/developer/libftdi/download/libftdi1-"
+ version ".tar.bz2"))
+ (sha256
+ (base32
+ "088yh8pxd6q53ssqndydcw1dkq51cjqyahc03lm6iip22cdazcf0"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("libusb" ,libusb)))
+ (home-page "http://www.intra2net.com")
+ (synopsis "FTDI USB driver with bitbang mode")
+ (description
+ "libFTDI is a library to talk to FTDI chips: FT232BM,
+FT245BM, FT2232C, FT2232D, FT245R and FT232H including the popular
+bitbangmode.")
+ (license lgpl2.1+)))