aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/libffi.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-12-03 08:52:17 +0100
committerLudovic Courtès <ludo@gnu.org>2018-12-03 08:52:17 +0100
commit194451347dc60092132d06b84a83c5205d79299a (patch)
tree828475b685c349cdd7b74c09beb7336d38bdf6f0 /gnu/packages/libffi.scm
parent37c6f11f8dfa1880db86a3510c9e50990304d76c (diff)
parent8cddb0d6363d13f74de5409ef29b7913228f49b9 (diff)
downloadpatches-194451347dc60092132d06b84a83c5205d79299a.tar
patches-194451347dc60092132d06b84a83c5205d79299a.tar.gz
Merge branch 'core-updates'
Diffstat (limited to 'gnu/packages/libffi.scm')
-rw-r--r--gnu/packages/libffi.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/libffi.scm b/gnu/packages/libffi.scm
index 0d54c305b2..01a5ea2049 100644
--- a/gnu/packages/libffi.scm
+++ b/gnu/packages/libffi.scm
@@ -50,7 +50,10 @@
(patches (search-patches "libffi-3.2.1-complex-alpha.patch"))))
(build-system gnu-build-system)
(arguments
- `(#:phases
+ `(;; Prevent the build system from passing -march and -mtune to the
+ ;; compiler. See "ax_cc_maxopt.m4" and "ax_gcc_archflag.m4".
+ #:configure-flags '("--enable-portable-binary" "--without-gcc-arch")
+ #:phases
(modify-phases %standard-phases
(add-after 'install 'post-install
(lambda* (#:key outputs #:allow-other-keys)
@@ -79,13 +82,14 @@ conversions for values passed between the two languages.")
(define-public python-cffi
(package
(name "python-cffi")
- (version "1.11.4")
+ (version "1.11.5")
(source
(origin
(method url-fetch)
(uri (pypi-uri "cffi" version))
(sha256
- (base32 "07fiy4wqg8g08x38r04ydjr8n6g0g74gb8si8b6jhymijalq746z"))))
+ (base32 "1x3lrj928dcxx1k8k9gf3s4s3jwvzv8mc3kkyg1g7c3a1sc1f3z9"))
+ (patches (search-patches "python-cffi-x87-stack-clean.patch"))))
(build-system python-build-system)
(outputs '("out" "doc"))
(inputs