summaryrefslogtreecommitdiff
path: root/gnu/packages/libevent.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-06-03 17:03:56 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-06-03 17:03:56 +0200
commit30e12b9664d774aca3948b1fa2e0aee6af09ca40 (patch)
tree483e1bfaad4671b922bb070a35da3ada819f9e50 /gnu/packages/libevent.scm
parent136b7d81f0eb713783e9ea7cf7f260a2b6252dfd (diff)
parent3092f1b835d79655eecb2f8a79dda20ad9ba6bd6 (diff)
downloadpatches-30e12b9664d774aca3948b1fa2e0aee6af09ca40.tar
patches-30e12b9664d774aca3948b1fa2e0aee6af09ca40.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/libevent.scm')
-rw-r--r--gnu/packages/libevent.scm23
1 files changed, 3 insertions, 20 deletions
diff --git a/gnu/packages/libevent.scm b/gnu/packages/libevent.scm
index 01e1e3b00a..bb96fd6abf 100644
--- a/gnu/packages/libevent.scm
+++ b/gnu/packages/libevent.scm
@@ -3,7 +3,7 @@
;;; Copyright © 2015, 2017 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
;;; Copyright © 2016 David Thompson <davet@gnu.org>
-;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2017, 2019 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Pierre Neidhardt <mail@ambrevar.xyz>
@@ -41,7 +41,7 @@
(define-public libevent
(package
(name "libevent")
- (version "2.1.8")
+ (version "2.1.10")
(source (origin
(method url-fetch)
(uri (string-append
@@ -49,11 +49,7 @@
version "-stable/libevent-" version "-stable.tar.gz"))
(sha256
(base32
- "1hhxnxlr0fsdv7bdmzsnhdz16fxf3jg2r6vyljcl3kj6pflcap4n"))
- (patches (search-patches "libevent-2.1-dns-tests.patch"
- ;; XXX: Try removing this for > 2.1.8.
- ;; https://github.com/libevent/libevent/issues/452
- "libevent-2.1-skip-failing-test.patch"))))
+ "1c25928gdv495clxk2v1d4gkr5py7ack4gx2n7d13frnld0syr78"))))
(build-system gnu-build-system)
(arguments
;; This skips some of the tests which fail on armhf and aarch64.
@@ -154,19 +150,6 @@ resolution, asynchronous file system operations, and threading primitives.")
;; details. Documentation is CC-BY 4.0 as of 1.12.0; see 'LICENSE-docs'.
(license (list expat cc-by4.0))))
-;; This version is required for Node versions < 10.
-(define-public libuv-1.19
- (package
- (inherit libuv)
- (version "1.19.2")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://dist.libuv.org/dist/v" version
- "/libuv-v" version ".tar.gz"))
- (sha256
- (base32
- "1msk9ac1z69whww88ibrwjqkd1apdla6l77cm2fwy5kigq0z5g3w"))))))
-
(define-public perl-anyevent
(package
(name "perl-anyevent")