summaryrefslogtreecommitdiff
path: root/gnu/packages/libcanberra.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-09-20 15:02:45 +0200
committerLudovic Courtès <ludo@gnu.org>2014-09-20 15:02:45 +0200
commit571a0310ff7e663c769d991ba93b6255f7e5b288 (patch)
tree419f682767f9cb4bc4dcfb7f0ea2937022e949d9 /gnu/packages/libcanberra.scm
parent0a9e9a6311ea1495b2b539ddc12df2aa33c3267d (diff)
downloadpatches-571a0310ff7e663c769d991ba93b6255f7e5b288.tar
patches-571a0310ff7e663c769d991ba93b6255f7e5b288.tar.gz
gnu: libcanberra: Add dependency on PulseAudio and eudev.
* gnu/packages/libcanberra.scm (libcanberra): Add PulseAudio and eudev as inputs.
Diffstat (limited to 'gnu/packages/libcanberra.scm')
-rw-r--r--gnu/packages/libcanberra.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/libcanberra.scm b/gnu/packages/libcanberra.scm
index 78c8326f24..2ea272ffb1 100644
--- a/gnu/packages/libcanberra.scm
+++ b/gnu/packages/libcanberra.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -25,6 +26,7 @@
#:use-module (gnu packages gstreamer)
#:use-module (gnu packages gtk)
#:use-module (gnu packages linux)
+ #:use-module (gnu packages pulseaudio)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages xiph))
@@ -46,12 +48,13 @@
"0wps39h8rx2b00vyvkia5j40fkak3dpipp1kzilqla0cgvk73dn2"))))
(build-system gnu-build-system)
(inputs
- ;; FIXME: Add optional inputs udev and pulse.
`(("alsa-lib" ,alsa-lib)
("gstreamer" ,gstreamer)
("gtk+" ,gtk+)
("libtool" ,libtool)
- ("libvorbis" ,libvorbis)))
+ ("libvorbis" ,libvorbis)
+ ("pulseaudio" ,pulseaudio)
+ ("udev" ,eudev)))
(native-inputs
`(("pkg-config" ,pkg-config)))
(home-page "http://0pointer.de/lennart/projects/libcanberra/")