summaryrefslogtreecommitdiff
path: root/gnu/packages/ldc.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2017-04-11 06:34:17 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2017-04-11 06:39:32 +0200
commitcd12f922246ae798ec248768713848d939d31ea0 (patch)
tree9e1f4f1d23139ff8afc3dda7f0ff36372b9f343f /gnu/packages/ldc.scm
parent0c3953ea603e6abd885a5a91b84f7f7788d0829f (diff)
downloadpatches-cd12f922246ae798ec248768713848d939d31ea0.tar
patches-cd12f922246ae798ec248768713848d939d31ea0.tar.gz
gnu: dub: Update to 1.3.0.
* gnu/packages/ldc.scm (dub): Update to 1.3.0. [arguments]: Add comment, remove spurious MKDIR-P, and rename OUTBIN.
Diffstat (limited to 'gnu/packages/ldc.scm')
-rw-r--r--gnu/packages/ldc.scm11
1 files changed, 5 insertions, 6 deletions
diff --git a/gnu/packages/ldc.scm b/gnu/packages/ldc.scm
index 881029a43d..42e6c04a84 100644
--- a/gnu/packages/ldc.scm
+++ b/gnu/packages/ldc.scm
@@ -279,7 +279,7 @@ latest DMD frontend and uses LLVM as backend.")
(define-public dub
(package
(name "dub")
- (version "1.2.2")
+ (version "1.3.0")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/dlang/dub/archive/"
@@ -287,22 +287,21 @@ latest DMD frontend and uses LLVM as backend.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "02k11x34nck0lbv13ww103niiswnwnslbnswj3b5faszzadbi1v4"))))
+ "056mvf01z51qc3i1qnx7yaqr728q8pss8zabiv5zpfx2ynfsw3k7"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; it would have tested itself by installing some packages (vibe etc)
#:phases
(modify-phases %standard-phases
- (delete 'configure)
+ (delete 'configure) ; no configure script
(replace 'build
(lambda _
(zero? (system* "./build.sh"))))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
- (outbin (string-append out "/bin")))
- (mkdir-p outbin)
- (install-file "bin/dub" outbin)
+ (bin (string-append out "/bin")))
+ (install-file "bin/dub" bin)
#t))))))
(inputs
`(("curl" ,curl)))