summaryrefslogtreecommitdiff
path: root/gnu/packages/kde.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-11-15 20:11:35 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-11-15 20:11:35 +0100
commitf056553c6b8ffa36f4ce9fb1c3602a8f4b1de242 (patch)
tree80c815216a3717cf00b615c9cb8840c113eaf79f /gnu/packages/kde.scm
parent2c9d34166983565120f831284df57a07e2edd2f9 (diff)
parent528b52390d216d8a8cd13dfcd1e6e40a6448e6c2 (diff)
downloadpatches-f056553c6b8ffa36f4ce9fb1c3602a8f4b1de242.tar
patches-f056553c6b8ffa36f4ce9fb1c3602a8f4b1de242.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/kde.scm')
-rw-r--r--gnu/packages/kde.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 9755f66aca..79eb20cb59 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2018 Gábor Boskovits <boskovits@gmail.com>
;;; Copyright © 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2018, 2019 Hartmut Goebel <h.goebel@crazy-compilers.com>
+;;; Copyright © 2019 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -626,3 +627,45 @@ communicate with each other. Here's a few things KDE Connect can do:
"Kqtquickcharts is a QtQuick plugin to render beautiful and interactive
charts.")
(license license:lgpl2.1+)))
+
+(define-public kcachegrind
+ (package
+ (name "kcachegrind")
+ (version "19.04.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/applications/" version
+ "/src/kcachegrind-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1hhsk64yp6q2xh8j269j4wp9y24ggmii861r6gf02mj1mbn2p1jb"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("perl" ,perl)
+ ("python" ,python)
+ ("qttools" ,qttools)
+ ("kdoctools" ,kdoctools)))
+ (inputs
+ `(("qtbase" ,qtbase)
+ ("karchive" ,karchive)
+ ("ki18n" ,ki18n)
+ ("kio" ,kio)
+ ("kdbusaddons" ,kdbusaddons)))
+ ;; Note: The 'hotshot2calltree' and 'pprof2calltree' scripts depend on
+ ;; Python and PHP, respectively. These are optional and we ignore them
+ ;; for now.
+ (home-page "https://kcachegrind.github.io/html/Home.html")
+ (synopsis "Visualize profiles produces by Valgrind's Cachegrind tool")
+ (description
+ "The data files generated by the Callgrind of Valgrind, an application
+profiler, can be loaded into KCachegrind for browsing the performance results.
+There is also a command-line tool to get ASCII reports from data files without
+the need to use KCachegrind.
+
+The format of Callgrind output is documented. With conversion scripts,
+KCachegrind is able to visualize output of other profilers like OProfile, a
+system-wide profiler for Linux using statistical sampling with hardware
+performance counters. There also exist converters for profiling output of
+Python, PHP, and Perl.")
+ (license license:gpl2)))