summaryrefslogtreecommitdiff
path: root/gnu/packages/kde.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-02-24 21:52:21 +0200
committerEfraim Flashner <efraim@flashner.co.il>2016-03-01 11:09:32 +0200
commitd34c594aeb01ea5de69909c97d1838da144d839b (patch)
tree7d415dcbcd70ff0cdb4ad4447ed93d98162c356a /gnu/packages/kde.scm
parentd8ea27820408551f1a5864dab5b14d6f368ded24 (diff)
downloadpatches-d34c594aeb01ea5de69909c97d1838da144d839b.tar
patches-d34c594aeb01ea5de69909c97d1838da144d839b.tar.gz
gnu: Add qca.
* gnu/packages/kde.scm: New file. * gnu-system.am (GNU_SYSTEM_MODULES): Register it.
Diffstat (limited to 'gnu/packages/kde.scm')
-rw-r--r--gnu/packages/kde.scm53
1 files changed, 53 insertions, 0 deletions
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
new file mode 100644
index 0000000000..64771fcd3b
--- /dev/null
+++ b/gnu/packages/kde.scm
@@ -0,0 +1,53 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages kde)
+ #:use-module (guix build-system cmake)
+ #:use-module (guix download)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix packages)
+ #:use-module (guix utils)
+ #:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages tls)
+ #:use-module (gnu packages qt))
+
+(define-public qca
+ (package
+ (name "qca")
+ (version "2.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://download.kde.org/stable/qca/" version
+ "/src/qca-" version ".tar.xz"))
+ (sha256
+ (base32
+ "10z9icq28fww4qbzwra8d9z55ywbv74qk68nhiqfrydm21wkxplm"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("openssl" ,openssl)
+ ("qt" ,qt)))
+ (home-page "http://delta.affinix.com/qca/")
+ (synopsis "Libraries for the Qt Cryptographic Architecture")
+ (description "The Qt Cryptographic Architecture (QCA) provides a
+straightforward and cross-platform API for a range of cryptographic features,
+including SSL/TLS, X.509 certificates, SASL, OpenPGP, S/MIME CMS, and smart
+cards.")
+ (license license:lgpl2.1)))