summaryrefslogtreecommitdiff
path: root/gnu/packages/kde.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-02-12 23:17:00 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-02-12 23:49:02 +0100
commitbec2a2e10e199d6ee671ec5713bd103242e91b62 (patch)
treebd481d4a1bc718ca663840e617359e98d9c35097 /gnu/packages/kde.scm
parent60562ec26bb512dbf9ea44de0df8b48f1f6e1880 (diff)
downloadpatches-bec2a2e10e199d6ee671ec5713bd103242e91b62.tar
patches-bec2a2e10e199d6ee671ec5713bd103242e91b62.tar.gz
gnu: Move KDE Plasma components to separate module.
* gnu/packages/kde.scm (libkscreen, libksysguard): Move from here ... * gnu/packages/kde-plasma.scm: ... to here. New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Adjust accordingly.
Diffstat (limited to 'gnu/packages/kde.scm')
-rw-r--r--gnu/packages/kde.scm103
1 files changed, 2 insertions, 101 deletions
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 5946ba0b52..ff26b0ea83 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2016, 2017 Thomas Danckaert <post@thomasdanckaert.be>
+;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
;;; Copyright © 2017, 2018 Mark Meyer <mark@ofosos.org>
;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Gábor Boskovits <boskovits@gmail.com>
@@ -36,11 +36,11 @@
#:use-module (gnu packages gettext)
#:use-module (gnu packages ghostscript)
#:use-module (gnu packages gl)
- #:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
#:use-module (gnu packages graphics)
#:use-module (gnu packages image)
#:use-module (gnu packages kde-frameworks)
+ #:use-module (gnu packages kde-plasma)
#:use-module (gnu packages llvm)
#:use-module (gnu packages maths)
#:use-module (gnu packages pdf)
@@ -480,105 +480,6 @@ used in KDE development tools Kompare and KDevelop.")
;; source archive
(license (list license:gpl2+ license:lgpl2.0+ license:bsd-3))))
-(define-public libkscreen
- (package
- (name "libkscreen")
- (version "5.13.5")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://kde/stable/plasma/" version "/"
- name "-" version ".tar.xz"))
- (sha256
- (base32 "04719va15i66qn1xqx318v6risxhp8bfcnhxh9mqm5h9qx5c6c4k"))))
- (build-system cmake-build-system)
- (native-inputs
- `(("extra-cmake-modules" ,extra-cmake-modules)
- ;; For testing.
- ("dbus" ,dbus)))
- (inputs
- `(("kwayland" ,kwayland)
- ("libxrandr" ,libxrandr)
- ("qtbase" ,qtbase)
- ("qtx11extras" ,qtx11extras)))
- (arguments
- '(#:tests? #f ; FIXME: 55% tests passed, 5 tests failed out of 11
- #:phases
- (modify-phases %standard-phases
- (add-before 'check 'pre-check
- (lambda _
- ;; For the missing '/etc/machine-id'.
- (setenv "DBUS_FATAL_WARNINGS" "0")
- ;; Run the tests offscreen.
- (setenv "QT_QPA_PLATFORM" "offscreen")
- #t)))))
- (home-page "https://community.kde.org/Solid/Projects/ScreenManagement")
- (synopsis "KDE's screen management software")
- (description "KScreen is the new screen management software for KDE Plasma
-Workspaces which tries to be as magic and automatic as possible for users with
-basic needs and easy to configure for those who want special setups.")
- (license license:gpl2+)))
-
-(define-public libksysguard
- (package
- (name "libksysguard")
- (version "5.13.4")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://kde//stable/plasma/" version
- "/libksysguard-" version ".tar.xz"))
- (sha256
- (base32
- "0k8q5bxk9zyv7c3nny1c399v8acqs618nw39q20pj2qdijl9ibvh"))))
- (native-inputs
- `(("extra-cmake-modules" ,extra-cmake-modules)
- ("pkg-config" ,pkg-config)))
- (inputs
- `(("kconfigwidgets" ,kconfigwidgets)
- ("kiconthemes" ,kiconthemes)
- ("kwindowsystem" ,kwindowsystem)
- ("ki18n" ,ki18n)
- ("kauth" ,kauth)
- ("kcompletion" ,kcompletion)
- ("kconfig" ,kconfig)
- ("kcoreaddons" ,kcoreaddons)
- ("kwidgetsaddons" ,kwidgetsaddons)
- ("kservice" ,kservice)
- ("qtbase" ,qtbase)
- ("qtscript" ,qtscript)
- ("qtwebkit" ,qtwebkit)
- ("qtx11extras" ,qtx11extras)
- ("plasma" ,plasma-framework)
- ("zlib" ,zlib)))
- (build-system cmake-build-system)
- (arguments
- `(#:configure-flags
- `(,(string-append "-DKDE_INSTALL_DATADIR="
- (assoc-ref %outputs "out") "/share"))
- #:phases
- (modify-phases %standard-phases
- (add-before 'configure 'patch-cmakelists
- (lambda _
- ;; TODO: Verify: This should no longer be necessary, since
- ;; KF5AuthConfig.cmake.in contains this already.
- (substitute* "processcore/CMakeLists.txt"
- (("KAUTH_HELPER_INSTALL_DIR") "KDE_INSTALL_LIBEXECDIR"))))
- (add-before 'check 'check-setup
- (lambda _
- ;; make Qt render "offscreen", required for tests
- (setenv "QT_QPA_PLATFORM" "offscreen")))
- (replace 'check
- (lambda _
- ;; TODO: Fix this failing test-case
- (invoke "ctest" "-E" "processtest"))))))
- (home-page "https://www.kde.org/info/plasma-5.13.4.php")
- (synopsis "Network enabled task and system monitoring")
- (description "KSysGuard can obtain information on system load and
-manage running processes. It obtains this information by interacting
-with a ksysguardd daemon, which may also run on a remote system.")
- (license license:gpl3+)))
-
(define-public qca
(package
(name "qca")