summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-frameworks.scm
diff options
context:
space:
mode:
authorThomas Danckaert <post@thomasdanckaert.be>2017-03-02 09:33:43 +0100
committerLudovic Courtès <ludo@gnu.org>2017-03-11 22:23:28 +0100
commit5578c2987e7657fd85fc0fb1c274ad00d4b173e9 (patch)
treee60efe1b4c5e9f1275cb7ce14105bcebd0f977b2 /gnu/packages/kde-frameworks.scm
parent612af7ff66e0d5018bb696ff0140805bc8b5194e (diff)
downloadpatches-5578c2987e7657fd85fc0fb1c274ad00d4b173e9.tar
patches-5578c2987e7657fd85fc0fb1c274ad00d4b173e9.tar.gz
gnu: phonon: Install Qt extensions.
* gnu/packages/kde-frameworks.scm (phonon)[arguments]: Add -DPHONON-INSTALL_QT_EXTENSIONS_INTO_SYSTEM_QT configure flag, and patch the installation directory. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/kde-frameworks.scm')
-rw-r--r--gnu/packages/kde-frameworks.scm14
1 files changed, 13 insertions, 1 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index ba4ead2d67..240e338ab7 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2016 David Craven <david@craven.ch>
+;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -119,7 +120,18 @@ common build settings used in software produced by the KDE community.")
(arguments
`(#:configure-flags
'("-DCMAKE_CXX_FLAGS=-fPIC"
- "-DPHONON_BUILD_PHONON4QT5=ON")))
+ "-DPHONON_BUILD_PHONON4QT5=ON"
+ "-DPHONON_INSTALL_QT_EXTENSIONS_INTO_SYSTEM_QT=ON")
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'install 'patch-installdir
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((regex (string-append "(INSTALL DESTINATION \")"
+ (assoc-ref inputs "qtbase"))))
+ (substitute* "cmake_install.cmake"
+ ((regex all dest)
+ (string-append dest (assoc-ref outputs "out")))))
+ #t)))))
(home-page "https://phonon.kde.org")
(synopsis "KDE's multimedia library")
(description "KDE's multimedia library.")