summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-frameworks.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2017-09-19 19:56:23 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2017-10-13 13:53:49 +0200
commit455a0bf50cc035cd6e1a68411dc68b4a505a9b5d (patch)
tree5a566b9bad70e02d25cc745a5173d486ead7c938 /gnu/packages/kde-frameworks.scm
parentcf7cf45a5fcd77a964c497299cd7bd60357f7758 (diff)
downloadpatches-455a0bf50cc035cd6e1a68411dc68b4a505a9b5d.tar
patches-455a0bf50cc035cd6e1a68411dc68b4a505a9b5d.tar.gz
gnu: kidletime: Enable fallback mode to X-Screensaver based poller.
This does no harm and reduced the number of warnings. Also pkg-config was added to reduce the number of warnings further. * gnu/packages/kde-frameworks.scm (kidletime)[inputs]: Add libxscrnsaver. [native-inputs]: Add pkg-config.
Diffstat (limited to 'gnu/packages/kde-frameworks.scm')
-rw-r--r--gnu/packages/kde-frameworks.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 507ec196b4..f4b9282033 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -747,9 +747,11 @@ translation scripting.")
"01m4q3l2yq83f2dpbv6jry7cjkj6bqdgfpy5b8byaf1gf9w2firs"))))
(build-system cmake-build-system)
(native-inputs
- `(("extra-cmake-modules" ,extra-cmake-modules)))
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("pkg-config" ,pkg-config)))
(inputs
- `(("qtbase" ,qtbase)
+ `(("libxscrnsaver" ,libxscrnsaver) ; X-Screensaver based poller, fallback mode
+ ("qtbase" ,qtbase)
("qtx11extras" ,qtx11extras)))
(home-page "https://community.kde.org/Frameworks")
(synopsis "Reporting of idle time of user and system")