summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-frameworks.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-11-29 19:13:40 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2016-11-29 19:13:40 +0100
commitdc2ef09ad79803f2cc4828ef18927ca0e75e24fa (patch)
tree10213d6ea0079e0d60c06aad428c83cb2148cf1c /gnu/packages/kde-frameworks.scm
parent7b722e3cba89977c14172ea44738704fcf6b250b (diff)
downloadpatches-dc2ef09ad79803f2cc4828ef18927ca0e75e24fa.tar
patches-dc2ef09ad79803f2cc4828ef18927ca0e75e24fa.tar.gz
gnu: kauth: Fix cmake macros to be used by other packages.
* gnu/packages/kde-framework.scm (kauth)[phases]: New phase fix-cmake-install-paths.
Diffstat (limited to 'gnu/packages/kde-frameworks.scm')
-rw-r--r--gnu/packages/kde-frameworks.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 4857cf2354..8b841330b8 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -1203,6 +1203,17 @@ uses a job-based interface to queue tasks and execute them in an efficient way."
(arguments
`(#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'fix-cmake-install-directories
+ (lambda _
+ ;; Make packages using kauth put their policy files and helpers
+ ;; into their own prefix.
+ (substitute* "KF5AuthConfig.cmake.in"
+ (("@KAUTH_POLICY_FILES_INSTALL_DIR@")
+ "${KDE_INSTALL_DATADIR}/polkit-1/actions")
+ (("@KAUTH_HELPER_INSTALL_DIR@")
+ "${KDE_INSTALL_LIBEXECDIR}")
+ (("@KAUTH_HELPER_INSTALL_ABSOLUTE_DIR@")
+ "${KDE_INSTALL_LIBEXECDIR}"))))
(replace 'check
(lambda _
(setenv "DBUS_FATAL_WARNINGS" "0")