summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-frameworks.scm
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-08-07 20:23:24 +0200
committerDavid Craven <david@craven.ch>2016-08-30 22:38:32 +0200
commite94177529357b6de9f93d07e21264f81f44d68ef (patch)
tree8058bec9e91867d8ea26af2aadf597969411a02b /gnu/packages/kde-frameworks.scm
parent85e831ec0c05bc4f3f9c9ef010be0a5139187719 (diff)
downloadpatches-e94177529357b6de9f93d07e21264f81f44d68ef.tar
patches-e94177529357b6de9f93d07e21264f81f44d68ef.tar.gz
gnu: Add krunner.
* gnu/packages/kde-frameworks.scm (krunner): New variable.
Diffstat (limited to 'gnu/packages/kde-frameworks.scm')
-rw-r--r--gnu/packages/kde-frameworks.scm54
1 files changed, 54 insertions, 0 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 11c019321b..8154a21fab 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -2320,3 +2320,57 @@ also provides facilities to integrate the data provided in user interfaces by
providing QML and Qt Widgets components. The sources are plugin-based, allowing
to easily extend the contacts collection.")
(license license:lgpl2.1+)))
+
+(define-public krunner
+ (package
+ (name "krunner")
+ (version "5.24.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/frameworks/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0ff87ijjd47jxf6zw2ggqgngnbyx1rj59wdfgy5wbi3acws6bafl"))))
+ (build-system cmake-build-system)
+ (propagated-inputs
+ `(("plasma-framework" ,plasma-framework)))
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)))
+ (inputs
+ `(("kauth" ,kauth)
+ ("kbookmarks" ,kbookmarks)
+ ("kcodecs" ,kcodecs)
+ ("kcompletion" ,kcompletion)
+ ("kconfig" ,kconfig)
+ ("kconfigwidgets" ,kconfigwidgets)
+ ("kcoreaddons" ,kcoreaddons)
+ ("kio" ,kio)
+ ("kitemviews" ,kitemviews)
+ ("ki18n" ,ki18n)
+ ("kjobwidgets" ,kjobwidgets)
+ ("kpackage" ,kpackage)
+ ("kservice" ,kservice)
+ ("kwidgetsaddons" ,kwidgetsaddons)
+ ("kxmlgui" ,kxmlgui)
+ ("qtbase" ,qtbase)
+ ("qtdeclarative" ,qtdeclarative)
+ ("solid" ,solid)
+ ("threadweaver" ,threadweaver)))
+ (arguments
+ `(#:tests? #f ; FIXME: 1/1 tests fail.
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'check-setup
+ (lambda _
+ (setenv "CTEST_OUTPUT_ON_FAILURE" "1") ; Enable debug output
+ (setenv "QT_QPA_PLATFORM" "offscreen"))))))
+ (home-page "https://community.kde.org/Frameworks")
+ (synopsis "Framework for Plasma runners")
+ (description "The Plasma workspace provides an application called KRunner
+which, among other things, allows one to type into a text area which causes
+various actions and information that match the text appear as the text is being
+typed.")
+ (license license:lgpl2.1+)))