summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-frameworks.scm
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-10-29 18:48:28 +0200
committerDavid Craven <david@craven.ch>2016-10-29 23:51:43 +0200
commita7ec016cd54294f8426033215cb517f9d4481e1f (patch)
treea9fcd6697b8be35753c382f68fba56aadcfd27eb /gnu/packages/kde-frameworks.scm
parent701d7a9b50d8645bb725c7b28e2399ce8101acff (diff)
downloadpatches-a7ec016cd54294f8426033215cb517f9d4481e1f.tar
patches-a7ec016cd54294f8426033215cb517f9d4481e1f.tar.gz
gnu: kplotting: Update to 5.27.0.
* gnu/packages/kde-frameworks.scm (kplotting): Update to 5.27.0 and fix indentation.
Diffstat (limited to 'gnu/packages/kde-frameworks.scm')
-rw-r--r--gnu/packages/kde-frameworks.scm34
1 files changed, 17 insertions, 17 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 6aaf8c16a8..ef77d8d127 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -768,16 +768,16 @@ to flat and hierarchical lists.")
(define-public kplotting
(package
(name "kplotting")
- (version "5.24.0")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://kde/stable/frameworks/"
- (version-major+minor version) "/"
- name "-" version ".tar.xz"))
- (sha256
- (base32
- "0gpypq9kh4b5s6dc7py3m117k3nbxczsfkxgxd9zxvr35kig7ya2"))))
+ (version "5.27.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://kde/stable/frameworks/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1qp9q8g9yxy359bylyqyqxjq9wjismajrg4xhxx5xn4s6znyrxny"))))
(build-system cmake-build-system)
(native-inputs
`(("extra-cmake-modules" ,extra-cmake-modules)
@@ -786,13 +786,13 @@ to flat and hierarchical lists.")
`(("qtbase" ,qtbase)))
(arguments
`(#:phases
- (modify-phases %standard-phases
- (add-before 'check 'start-xorg-server
- (lambda* (#:key inputs #:allow-other-keys)
- ;; The test suite requires a running X server.
- (system (string-append (assoc-ref inputs "xorg-server")
- "/bin/Xvfb :1 &"))
- (setenv "DISPLAY" ":1")
+ (modify-phases %standard-phases
+ (add-before 'check 'start-xorg-server
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; The test suite requires a running X server.
+ (system (string-append (assoc-ref inputs "xorg-server")
+ "/bin/Xvfb :1 &"))
+ (setenv "DISPLAY" ":1")
#t)))))
(home-page "https://community.kde.org/Frameworks")
(synopsis "Data plotting library")