summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-frameworks.scm
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-08-07 20:26:02 +0200
committerDavid Craven <david@craven.ch>2016-08-30 22:38:32 +0200
commit7ac520dd2257e7903de855aba821a6e061cac0e4 (patch)
treef48c18f900ff13adcf3de55e4ceef5eb285c92a9 /gnu/packages/kde-frameworks.scm
parent2128da9a98250881d6796d3b40a18a94f5624724 (diff)
downloadpatches-7ac520dd2257e7903de855aba821a6e061cac0e4.tar
patches-7ac520dd2257e7903de855aba821a6e061cac0e4.tar.gz
gnu: Add kwallet.
* gnu/packages/kde-frameworks.scm (kwallet): New variable.
Diffstat (limited to 'gnu/packages/kde-frameworks.scm')
-rw-r--r--gnu/packages/kde-frameworks.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 17ccafb53a..de6d2cf250 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -2530,3 +2530,44 @@ library.")
It supports rich text as well as plain text.")
;; dual licensed
(license (list license:lgpl2.0+ license:lgpl2.1+))))
+
+(define-public kwallet
+ (package
+ (name "kwallet")
+ (version "5.24.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/frameworks/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0zad5h4vsvcl2xv3vxsjwh42b71xbp6x6rj8cvmw8szr2rzz9gsx"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)))
+ (inputs
+ `(("gpgmepp" ,gpgmepp)
+ ("kauth" ,kauth)
+ ("kcodecs" ,kcodecs)
+ ("kconfig" ,kconfig)
+ ("kconfigwidgets" ,kconfigwidgets)
+ ("kcoreaddons" ,kcoreaddons)
+ ("kdbusaddons" ,kdbusaddons)
+ ("kdoctools" ,kdoctools)
+ ("kiconthemes" ,kiconthemes)
+ ("ki18n" ,ki18n)
+ ("knotifications" ,knotifications)
+ ("kservice" ,kservice)
+ ("kwidgetsaddons" ,kwidgetsaddons)
+ ("kwindowsystem" ,kwindowsystem)
+ ("libgcrypt" ,libgcrypt)
+ ("phonon" ,phonon)
+ ("qtbase" ,qtbase)))
+ (home-page "https://community.kde.org/Frameworks")
+ (synopsis "Safe desktop-wide storage for passwords")
+ (description "This framework contains an interface to KWallet, a safe
+desktop-wide storage for passwords and the kwalletd daemon used to safely store
+the passwords on KDE work spaces.")
+ (license license:lgpl2.1+)))