summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-frameworks.scm
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-10-29 18:48:28 +0200
committerDavid Craven <david@craven.ch>2016-10-29 23:51:43 +0200
commit3dfcaf33c8649a3593617c6fc36e9c3af3adb792 (patch)
tree54770dd19b98ccd7f1c250ce77bf2f6eeb2ae227 /gnu/packages/kde-frameworks.scm
parenta7ec016cd54294f8426033215cb517f9d4481e1f (diff)
downloadpatches-3dfcaf33c8649a3593617c6fc36e9c3af3adb792.tar
patches-3dfcaf33c8649a3593617c6fc36e9c3af3adb792.tar.gz
gnu: kwayland: Update to 5.27.0.
* gnu/packages/kde-frameworks.scm (kwayland): Update to 5.27.0 and fix indentation.
Diffstat (limited to 'gnu/packages/kde-frameworks.scm')
-rw-r--r--gnu/packages/kde-frameworks.scm29
1 files changed, 15 insertions, 14 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index ef77d8d127..bf61f67003 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -806,16 +806,16 @@ pixel units.")
(define-public kwayland
(package
(name "kwayland")
- (version "5.24.0")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://kde/stable/frameworks/"
- (version-major+minor version) "/"
- name "-" version ".tar.xz"))
- (sha256
- (base32
- "1h5anbqrxcl1s8kx1l53vcsfr8ifamcjqd47dk8a7lwr1ga6myq2"))))
+ (version "5.27.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://kde/stable/frameworks/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0va1kmki2xr4mx2918h333mfkqs5v1mhbzyf71hq190izdz0jdss"))))
(build-system cmake-build-system)
(native-inputs
`(("extra-cmake-modules" ,extra-cmake-modules)
@@ -827,10 +827,11 @@ pixel units.")
`(#:tests? #f ; FIXME tests require weston to run
; weston requires wayland flags in mesa
#:phases
- (modify-phases %standard-phases
- (add-before 'check 'check-setup
- (lambda* _
- (setenv "XDG_RUNTIME_DIR" "/tmp"))))))
+ (modify-phases %standard-phases
+ (add-before 'check 'check-setup
+ (lambda _
+ (setenv "XDG_RUNTIME_DIR" "/tmp")
+ #t)))))
(home-page "https://community.kde.org/Frameworks")
(synopsis "Qt-style API to interact with the wayland client and server")
(description "As the names suggest they implement a Client respectively a