summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-frameworks.scm
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-08-07 20:23:57 +0200
committerDavid Craven <david@craven.ch>2016-08-30 22:38:32 +0200
commit12b49b623417acf348502d9a506f0f10af125244 (patch)
tree36457eee4a18ce839d7d8f22639f0dbfe011bb0b /gnu/packages/kde-frameworks.scm
parente94177529357b6de9f93d07e21264f81f44d68ef (diff)
downloadpatches-12b49b623417acf348502d9a506f0f10af125244.tar
patches-12b49b623417acf348502d9a506f0f10af125244.tar.gz
gnu: Add kservice.
* gnu/packages/kde-frameworks.scm (kservice): New variable.
Diffstat (limited to 'gnu/packages/kde-frameworks.scm')
-rw-r--r--gnu/packages/kde-frameworks.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 8154a21fab..f5368617c5 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -2374,3 +2374,46 @@ which, among other things, allows one to type into a text area which causes
various actions and information that match the text appear as the text is being
typed.")
(license license:lgpl2.1+)))
+
+(define-public kservice
+ (package
+ (name "kservice")
+ (version "5.24.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/frameworks/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0w0nsg64d6xhgijr2vh0j5p544qi0q55jpqa9v9mv956zrrdssdk"))))
+ (build-system cmake-build-system)
+ (propagated-inputs
+ `(("kconfig" ,kconfig)
+ ("kcoreaddons" ,kcoreaddons)))
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)))
+ (inputs
+ `(("kcrash" ,kcrash)
+ ("kdbusaddons" ,kdbusaddons)
+ ("kdoctools" ,kdoctools)
+ ("ki18n" ,ki18n)
+ ("qtbase" ,qtbase)))
+ (arguments
+ `(#:tests? #f ; FIXME: 8/10 tests fail.
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'check-setup
+ (lambda _
+ (setenv "HOME" (getcwd))
+ (setenv "CTEST_OUTPUT_ON_FAILURE" "1")
+ (setenv "QT_QPA_PLATFORM" "offscreen")
+ #t)))))
+ (home-page "https://community.kde.org/Frameworks")
+ (synopsis "Plugin framework for desktop services")
+ (description "KService provides a plugin framework for handling desktop
+services. Services can be applications or libraries. They can be bound to MIME
+types or handled by application specific code.")
+ ;; triple licensed
+ (license (list license:gpl2+ license:gpl3+ license:lgpl2.1+))))