summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-frameworks.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2019-01-09 15:54:55 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2019-01-11 16:35:52 +0100
commit46b082f97f73cd79b40bde15cfe3e4ddb28ba209 (patch)
treeb008756b14819dd4a7077a30b34f471a7930f285 /gnu/packages/kde-frameworks.scm
parent5a26f879c3f2f417f594171d909acc3f8227a99c (diff)
downloadpatches-46b082f97f73cd79b40bde15cfe3e4ddb28ba209.tar
patches-46b082f97f73cd79b40bde15cfe3e4ddb28ba209.tar.gz
gnu: kinit: Use KDEINIT5_LIBRARY_PATH to search for dynlibs.
Using LIBRARY_PATH was introduced in 16b8aff85bcdb9799496c4a27257210cd45158e5, but is wrong since this variable is used by the compiler (gcc) at link time. * gnu/packages/patches/kinit-kdeinit-libpath.patch: Change LIBRARY_PATH to KDEINIT5_LIBRARY_PATH. * gnu/packages/kde-frameworks.scm (kinit)[native-search-paths]: New field.
Diffstat (limited to 'gnu/packages/kde-frameworks.scm')
-rw-r--r--gnu/packages/kde-frameworks.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 0d14c8f887..fff98bd16d 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -2556,6 +2556,10 @@ in applications using the KDE Frameworks.")
(("GUIX_PKGS_KF5_PARTS") (assoc-ref inputs "kparts"))
(("GUIX_PKGS_KF5_PLASMA") (assoc-ref inputs "plasma-framework")))
#t)))))
+ (native-search-paths
+ (list (search-path-specification
+ (variable "KDEINIT5_LIBRARY_PATH")
+ (files '("lib/")))))
(native-inputs
`(("extra-cmake-modules" ,extra-cmake-modules)
("pkg-config" ,pkg-config)))