summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-frameworks.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2017-09-26 10:18:46 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2017-10-13 13:53:48 +0200
commitbb4fcf7ba6c361f45215c0200515b7270d93dbdc (patch)
tree2dc497db279f3d4b74c6b13f0b3e86b246b1b1ca /gnu/packages/kde-frameworks.scm
parent3d7bb7b304b2758dc160e0b7a9f9db1400183091 (diff)
downloadpatches-bb4fcf7ba6c361f45215c0200515b7270d93dbdc.tar
patches-bb4fcf7ba6c361f45215c0200515b7270d93dbdc.tar.gz
gnu: kio: Adopt a patch from Nix.
* gnu/package/kde-frameworks.scm (kio)[arguments] <#:phases>'patch': New phase.
Diffstat (limited to 'gnu/packages/kde-frameworks.scm')
-rw-r--r--gnu/packages/kde-frameworks.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 4a13329ae9..01cc4ee099 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -2446,6 +2446,14 @@ makes starting KDE applications faster and reduces memory consumption.")
`(#:tests? #f ; FIXME: 41/50 tests fail.
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'patch
+ (lambda _
+ ;; Better error message (taken from nix)
+ (substitute* "src/kiod/kiod_main.cpp"
+ (("(^\\s*qCWarning(KIOD_CATEGORY) << \"Error loading plugin:\")( << loader.errorString();)" _ a b)
+ (string-append a "<< name" b)))
+ ;; TODO: samba-search-path.patch from nix: search smbd on $PATH
+ #t))
(add-before 'check 'check-setup
(lambda _
(setenv "HOME" (getcwd))