summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-frameworks.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2017-11-01 16:56:48 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2017-11-05 10:56:39 +0100
commit39d1a429fe48b1e3ee1530a22d60acde3c4d1077 (patch)
tree94ecaec5a4a52a9a74a218a0da2e75436aeec123 /gnu/packages/kde-frameworks.scm
parent571f1fa3b2b0068fcc65e3a879cef37a87312a19 (diff)
downloadpatches-39d1a429fe48b1e3ee1530a22d60acde3c4d1077.tar
patches-39d1a429fe48b1e3ee1530a22d60acde3c4d1077.tar.gz
gnu: kactivities: Move to tier 2.
KDE now lists this package as tier 2, I was trapped by the definitions being at the wrong place. * gnu/packages/kde-frameworks.scm (kactivities): Move into the "section" of tier 2 packages. (kactivities-stats) Remove now obsolete comment.
Diffstat (limited to 'gnu/packages/kde-frameworks.scm')
-rw-r--r--gnu/packages/kde-frameworks.scm92
1 files changed, 45 insertions, 47 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index f8eb504d80..beac86f597 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -1320,6 +1320,51 @@ uses a job-based interface to queue tasks and execute them in an efficient way."
;; Tier 2 frameworks additionally depend on tier 1 frameworks, but still have
;; easily manageable dependencies.
+(define-public kactivities
+ (package
+ (name "kactivities")
+ (version "5.39.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://kde/stable/frameworks/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0nkc1p7n6yvybcib6aqmnz08hwn3ryj1f9wbkiimgs0svr00sslq"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)))
+ (inputs
+ `(("boost" ,boost)
+ ("kauth" ,kauth)
+ ("kbookmarks" ,kbookmarks)
+ ("kcodecs" ,kcodecs)
+ ("kcompletion" ,kcompletion)
+ ("kconfig" ,kconfig)
+ ("kconfigwidgets" ,kconfigwidgets)
+ ("kcoreaddons" ,kcoreaddons)
+ ("kio" ,kio)
+ ("kitemviews" ,kitemviews)
+ ("kjobwidgets" ,kjobwidgets)
+ ("kservice" ,kservice)
+ ("kwidgetsaddons" ,kwidgetsaddons)
+ ("kwindowsystem" ,kwindowsystem)
+ ("kxmlgui" ,kxmlgui)
+ ("qtbase" ,qtbase)
+ ("qtdeclarative" ,qtdeclarative)
+ ("solid" ,solid)))
+ (home-page "https://community.kde.org/Frameworks")
+ (synopsis "Core components for the KDE Activity concept")
+ (description "KActivities provides the infrastructure needed to manage a
+user's activities, allowing them to switch between tasks, and for applications
+to update their state to match the user's current activity. This includes a
+daemon, a library for interacting with that daemon, and plugins for integration
+with other frameworks.")
+ ;; triple licensed
+ (license (list license:gpl2+ license:lgpl2.0+ license:lgpl2.1+))))
+
(define-public kauth
(package
(name "kauth")
@@ -1862,53 +1907,6 @@ maintaining an index of the contents of your files.")
;; dual licensed
(license (list license:gpl2+ license:lgpl2.1+))))
-(define-public kactivities
- (package
- (name "kactivities")
- (version "5.39.0")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "mirror://kde/stable/frameworks/"
- (version-major+minor version) "/"
- name "-" version ".tar.xz"))
- (sha256
- (base32
- "0nkc1p7n6yvybcib6aqmnz08hwn3ryj1f9wbkiimgs0svr00sslq"))))
- (build-system cmake-build-system)
- (native-inputs
- `(("extra-cmake-modules" ,extra-cmake-modules)))
- (inputs
- `(("boost" ,boost)
- ("kauth" ,kauth)
- ("kbookmarks" ,kbookmarks)
- ("kcodecs" ,kcodecs)
- ("kcompletion" ,kcompletion)
- ("kconfig" ,kconfig)
- ("kconfigwidgets" ,kconfigwidgets)
- ("kcoreaddons" ,kcoreaddons)
- ("kio" ,kio)
- ("kitemviews" ,kitemviews)
- ("kjobwidgets" ,kjobwidgets)
- ("kservice" ,kservice)
- ("kwidgetsaddons" ,kwidgetsaddons)
- ("kwindowsystem" ,kwindowsystem)
- ("kxmlgui" ,kxmlgui)
- ("qtbase" ,qtbase)
- ("qtdeclarative" ,qtdeclarative)
- ("solid" ,solid)))
- (home-page "https://community.kde.org/Frameworks")
- (synopsis "Core components for the KDE Activity concept")
- (description "KActivities provides the infrastructure needed to manage a
-user's activities, allowing them to switch between tasks, and for applications
-to update their state to match the user's current activity. This includes a
-daemon, a library for interacting with that daemon, and plugins for integration
-with other frameworks.")
- ;; triple licensed
- (license (list license:gpl2+ license:lgpl2.0+ license:lgpl2.1+))))
-
-;; NOTE: This package is listed as a tier 2 package even though it requires
-;; kactivities - a tier 3 package.
(define-public kactivities-stats
(package
(name "kactivities-stats")