summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-frameworks.scm
diff options
context:
space:
mode:
authorThomas Danckaert <post@thomasdanckaert.be>2017-03-02 11:20:53 +0100
committerLudovic Courtès <ludo@gnu.org>2017-03-11 22:23:28 +0100
commit4bff300b5356d40475eb9d1a4deafcdcb0fa0441 (patch)
tree9ae5497f529dcb8439ef19ea5f94d534f1d55924 /gnu/packages/kde-frameworks.scm
parent5578c2987e7657fd85fc0fb1c274ad00d4b173e9 (diff)
downloadpatches-4bff300b5356d40475eb9d1a4deafcdcb0fa0441.tar
patches-4bff300b5356d40475eb9d1a4deafcdcb0fa0441.tar.gz
gnu: Add phonon-backend-gstreamer.
* gnu/packages/kde-frameworks.scm (phonon-backend-gstreamer): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/kde-frameworks.scm')
-rw-r--r--gnu/packages/kde-frameworks.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 240e338ab7..4359636285 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -43,6 +43,7 @@
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
#:use-module (gnu packages gnupg)
+ #:use-module (gnu packages gstreamer)
#:use-module (gnu packages linux)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
@@ -137,6 +138,41 @@ common build settings used in software produced by the KDE community.")
(description "KDE's multimedia library.")
(license license:lgpl2.1+)))
+(define-public phonon-backend-gstreamer
+ (package
+ (name "phonon-backend-gstreamer")
+ (version "4.9.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://kde/stable/phonon/"
+ name "/" version "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1wc5p1rqglf0n1avp55s50k7fjdzdrhg0gind15k8796w7nfbhyf"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("qtbase" ,qtbase)
+ ("phonon" ,phonon)
+ ("qtbase" ,qtbase)
+ ("qtx11extras" ,qtx11extras)
+ ("gstreamer" ,gstreamer)
+ ("gst-plugins-base" ,gst-plugins-base)
+ ("libxml2" ,libxml2)))
+ (arguments
+ `(#:configure-flags
+ '( "-DPHONON_BUILD_PHONON4QT5=ON")))
+ (home-page "https://phonon.kde.org")
+ (synopsis "Phonon backend which uses GStreamer")
+ (description "Phonon makes use of backend libraries to provide sound.
+Phonon-GStreamer is a backend based on the GStreamer multimedia library.")
+ ;; license: source files mention "either version 2.1 or 3"
+ (license (list license:lgpl2.1 license:lgpl3))))
+
(define-public gpgmepp
(package
(name "gpgmepp")