summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-frameworks.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2018-12-20 11:50:07 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2019-01-04 10:01:08 +0100
commit69b608618285d5c2d318feeb93b56c4d5a441ede (patch)
tree66bc28429603f5d4e35dfbb4059c5c04c14ab063 /gnu/packages/kde-frameworks.scm
parentac277bc7c5eec73f78321b41c80b90c53b951acc (diff)
downloadpatches-69b608618285d5c2d318feeb93b56c4d5a441ede.tar
patches-69b608618285d5c2d318feeb93b56c4d5a441ede.tar.gz
gnu: extra-cmake-modules: Fix install-path for plugins.
The respective entry changed for kde-frameworks 5.46. * gnu/packages/kde-frameworks.scm(krunner)[#phases]<fix-lib-path>: Change substitute for QTPLUGINDIR.
Diffstat (limited to 'gnu/packages/kde-frameworks.scm')
-rw-r--r--gnu/packages/kde-frameworks.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 6c1854379a..0f3790367f 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -98,8 +98,10 @@
(("\"lib64\"") "\"lib\"")
;; TODO: Base the following on values taken from Qt
;; Install plugins into lib/qt5/plugins
- (("_define_relative\\(QTPLUGINDIR LIBDIR \"plugins\"")
- "_define_relative(QTPLUGINDIR LIBDIR \"qt5/plugins\"")
+ ;; TODO: Check if this is okay for Android, too
+ ;; (see comment in KDEInstallDirs.cmake)
+ (("_define_relative\\(QTPLUGINDIR \"\\$\\{_pluginsDirParent}\" \"plugins\"")
+ "_define_relative(QTPLUGINDIR \"${_pluginsDirParent}\" \"qt5/plugins\"")
;; Install imports into lib/qt5/imports
(("_define_relative\\(QTQUICKIMPORTSDIR QTPLUGINDIR \"imports\"")
"_define_relative(QTQUICKIMPORTSDIR LIBDIR \"qt5/imports\"")