summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-frameworks.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2017-09-26 20:23:42 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2017-10-13 13:53:51 +0200
commitb87633fc0f98864ecdd96a6c55c7f89e8b2c598d (patch)
treec2a6ebc81b70f2203286bec4f02d3787b1f4d00f /gnu/packages/kde-frameworks.scm
parentd3726f0587f7108884b35a69c65be3313b16ac24 (diff)
downloadpatches-b87633fc0f98864ecdd96a6c55c7f89e8b2c598d.tar
patches-b87633fc0f98864ecdd96a6c55c7f89e8b2c598d.tar.gz
gnu: ktexteditor: Symlink some files referred to by different names.
* gnu/package/kde-frameworks.scm (ktexteditor)[arguments] <#:phases>'add-symlinks': New phase.
Diffstat (limited to 'gnu/packages/kde-frameworks.scm')
-rw-r--r--gnu/packages/kde-frameworks.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index b9ddc03113..3bffeb26b2 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -2849,7 +2849,16 @@ types or handled by application specific code.")
(setenv "HOME" (getcwd))
;; make Qt render "offscreen", required for tests
(setenv "QT_QPA_PLATFORM" "offscreen")
- #t)))))
+ #t))
+ (add-after 'install 'add-symlinks
+ ;; Some package(s) (e.g. plasma-sdk) refer to these service types
+ ;; by the wrong name. I would prefer to patch those packages, but
+ ;; I cannot find the files!
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((kst5 (string-append (assoc-ref outputs "out")
+ "/share/kservicetypes5/")))
+ (symlink (string-append kst5 "ktexteditorplugin.desktop")
+ (string-append kst5 "ktexteditor-plugin.desktop"))))))))
(home-page "https://community.kde.org/Frameworks")
(synopsis "Full text editor component")
(description "KTextEditor provides a powerful text editor component that you