summaryrefslogtreecommitdiff
path: root/gnu/packages/jupyter.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-10-12 18:37:29 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-10-12 18:39:58 +0200
commit9f294736b247c55c65bb1a7053e1c98d9bfa161c (patch)
tree3c8996a223f835b6e96657317a219016d57915a2 /gnu/packages/jupyter.scm
parentff97c862958095c9df0b41eb0574e7529ffab123 (diff)
downloadpatches-9f294736b247c55c65bb1a7053e1c98d9bfa161c.tar
patches-9f294736b247c55c65bb1a7053e1c98d9bfa161c.tar.gz
gnu: python-jupyter-kernel-test: Use PYTHON-VERSION.
* gnu/packages/jupyter.scm (python-jupyter-kernel-test)[arguments]: Use PYTHON-VERSION to determite Python version.
Diffstat (limited to 'gnu/packages/jupyter.scm')
-rw-r--r--gnu/packages/jupyter.scm4
1 files changed, 1 insertions, 3 deletions
diff --git a/gnu/packages/jupyter.scm b/gnu/packages/jupyter.scm
index 7ec987b2a4..fbb4367ea5 100644
--- a/gnu/packages/jupyter.scm
+++ b/gnu/packages/jupyter.scm
@@ -118,9 +118,7 @@ launching and using Jupyter kernels.")
(replace 'install
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
- (version ((@@ (guix build python-build-system)
- get-python-version)
- (assoc-ref inputs "python")))
+ (version (python-version (assoc-ref inputs "python")))
(pydir (string-append out "/lib/python"
version "/site-packages/"
"jupyter_kernel_test")))