summaryrefslogtreecommitdiff
path: root/gnu/packages/jupyter.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-11-28 21:40:13 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-12-04 20:10:34 +0100
commit936aa05209402dd399869ffae188db5dd5f67d69 (patch)
tree281017ffb73bf324c0921f8efe836fcbc2d68eba /gnu/packages/jupyter.scm
parent208e743415d7c36e9684851a31cc30dec16db2c3 (diff)
downloadpatches-936aa05209402dd399869ffae188db5dd5f67d69.tar
patches-936aa05209402dd399869ffae188db5dd5f67d69.tar.gz
gnu: Remove duplicate nlohmann-json-cpp package.
* gnu/packages/serialization.scm (nlohmann-json-cpp): Move variable ... * gnu/packages/cpp.scm (nlohmann-json-cpp): ... here. Mark as deprecated by JSON-MODERN-CXX. * gnu/packages/jupyter.scm (xeus)[inputs]: Change NLOHMANN-JSON-CPP to JSON-MODERN-CXX. * gnu/packages/video.scm (mkvtoolnix)[inputs]: Likewise.
Diffstat (limited to 'gnu/packages/jupyter.scm')
-rw-r--r--gnu/packages/jupyter.scm3
1 files changed, 1 insertions, 2 deletions
diff --git a/gnu/packages/jupyter.scm b/gnu/packages/jupyter.scm
index fbb4367ea5..e65a8bd6c9 100644
--- a/gnu/packages/jupyter.scm
+++ b/gnu/packages/jupyter.scm
@@ -30,7 +30,6 @@
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
#:use-module (gnu packages python-xyz)
- #:use-module (gnu packages serialization)
#:use-module (gnu packages time)
#:use-module (gnu packages tls))
@@ -168,7 +167,7 @@ Messaging Protocol}.")
("python-jupyter-client" ,python-jupyter-client)))
(inputs
`(("xtl" ,xtl)
- ("nlohmann-json-cpp" ,nlohmann-json-cpp)
+ ("json-modern-cxx" ,json-modern-cxx)
("cppzmq" ,cppzmq)
("zeromq" ,zeromq)
("openssl" ,openssl)