summaryrefslogtreecommitdiff
path: root/gnu/packages/julia.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-07-20 11:36:33 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-07-20 11:37:01 +0300
commit5f01078129f4eaa4760a14f22761cf357afb6738 (patch)
treef0b990753594ca38688d42e935cd5057f1204232 /gnu/packages/julia.scm
parentc23c628ea7a6435460d12969af5a3ba0e8d82004 (diff)
downloadpatches-5f01078129f4eaa4760a14f22761cf357afb6738.tar
patches-5f01078129f4eaa4760a14f22761cf357afb6738.tar.gz
gnu: julia: Build with zlib.
* gnu/packages/julia.scm (julia)[inputs]: Add zlib.
Diffstat (limited to 'gnu/packages/julia.scm')
-rw-r--r--gnu/packages/julia.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/gnu/packages/julia.scm b/gnu/packages/julia.scm
index 1cda5d89c8..e3cefb4330 100644
--- a/gnu/packages/julia.scm
+++ b/gnu/packages/julia.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015, 2016 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -26,6 +27,7 @@
#:use-module (gnu packages)
#:use-module (gnu packages algebra)
#:use-module (gnu packages base)
+ #:use-module (gnu packages compression)
#:use-module (gnu packages elf)
#:use-module (gnu packages gcc)
#:use-module (gnu packages llvm)
@@ -262,6 +264,7 @@
("mpfr" ,mpfr)
("wget" ,wget)
("which" ,which)
+ ("zlib" ,zlib)
("gmp" ,gmp)
;; FIXME: The following inputs are downloaded from upstream to allow us
;; to use the lightweight Julia release tarball. Ideally, these inputs