aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/jemalloc.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-09-02 15:57:56 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-09-02 15:57:56 +0200
commit30dfac27a5642c36e7bb1ba7966566864ba2d28d (patch)
tree3b59623014eeea1df02cda5f926d803b9a36a828 /gnu/packages/jemalloc.scm
parentd2ee294c0400ac8f2a10f10c3c9644da513a3712 (diff)
parent65e4109cdc96fbaee088f50d0138af8acef43141 (diff)
downloadpatches-30dfac27a5642c36e7bb1ba7966566864ba2d28d.tar
patches-30dfac27a5642c36e7bb1ba7966566864ba2d28d.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/jemalloc.scm')
-rw-r--r--gnu/packages/jemalloc.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/jemalloc.scm b/gnu/packages/jemalloc.scm
index 27fb46e59d..a3bd2c93a4 100644
--- a/gnu/packages/jemalloc.scm
+++ b/gnu/packages/jemalloc.scm
@@ -23,14 +23,13 @@
#:use-module ((guix licenses) #:select (bsd-2))
#:use-module (guix packages)
#:use-module (guix download)
- #:use-module (gnu packages base)
- #:use-module (gnu packages gcc)
+ #:use-module (gnu packages perl)
#:use-module (guix build-system gnu))
(define-public jemalloc
(package
(name "jemalloc")
- (version "4.5.0")
+ (version "5.0.1")
(source (origin
(method url-fetch)
(uri (string-append
@@ -38,7 +37,7 @@
version "/jemalloc-" version ".tar.bz2"))
(sha256
(base32
- "10373xhpc10pgmai9fkc1z0rs029qlcb3c0qfnvkbwdlcibdh2cl"))))
+ "1sf3lzgb0y8nnyzmp4zrca3sngdxw3kfh20sna9z03jv74fph528"))))
(build-system gnu-build-system)
(arguments
`(#:phases
@@ -56,6 +55,7 @@
;; Transparent huge pages are only enabled by default on Intel processors
'()
'(#:configure-flags (list "--disable-thp")))))
+ (inputs `(("perl" ,perl)))
(home-page "http://jemalloc.net/")
(synopsis "General-purpose scalable concurrent malloc implementation")
(description