summaryrefslogtreecommitdiff
path: root/gnu/packages/java.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2017-10-01 18:59:49 +0200
committerJulien Lepiller <julien@lepiller.eu>2017-10-03 21:38:56 +0200
commit2b1fdb2b65690df1a4ef0a45280af0564870909f (patch)
tree35ff72ab68a1ae58dd6b14e11e846e2dffe071df /gnu/packages/java.scm
parent27103135ddbdfc3b2b6819c2706658834e5e9987 (diff)
downloadpatches-2b1fdb2b65690df1a4ef0a45280af0564870909f.tar
patches-2b1fdb2b65690df1a4ef0a45280af0564870909f.tar.gz
gnu: Add java-osgi-service-metatype-annotations.
* gnu/packages/java.scm (java-osgi-service-metatype-annotations): New variable.
Diffstat (limited to 'gnu/packages/java.scm')
-rw-r--r--gnu/packages/java.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 17c05f3f23..5e825485cd 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -5026,3 +5026,30 @@ and service platform for the Java programming language. This package contains
an interface and utilitary classes for promises. A Promise represents a future
value. It handles the interactions for asynchronous processing.")
(license license:asl2.0)))
+
+(define-public java-osgi-service-metatype-annotations
+ (package
+ (name "java-osgi-service-metatype-annotations")
+ (version "1.3.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://central.maven.org/maven2/org/osgi/"
+ "org.osgi.service.metatype.annotations/"
+ version "/org.osgi.service.metatype.annotations-"
+ version "-sources.jar"))
+ (sha256
+ (base32
+ "12rwm3349wk80vm88rcdgs4435m4jxkpkj5mrx326skkz2c6hyw6"))))
+ (build-system ant-build-system)
+ (arguments
+ `(#:jar-name "osgi-service-metatype-annotations.jar"
+ #:tests? #f)); no tests
+ (inputs
+ `(("annotation" ,java-osgi-annotation)))
+ (home-page "http://www.osgi.org")
+ (synopsis "Support annotations for metatype")
+ (description
+ "OSGi, for Open Services Gateway initiative framework, is a module system
+and service platform for the Java programming language. This package contains
+the support annotations for metatype.")
+ (license license:asl2.0)))