summaryrefslogtreecommitdiff
path: root/gnu/packages/java.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas.enge@inria.fr>2016-06-24 16:19:45 +0200
committerAndreas Enge <andreas@enge.fr>2016-06-24 16:21:54 +0200
commitb8a680f778c021c91eaaaab4798bdcc7d417dce2 (patch)
treef85901bd8ec2df3d3e93a14157053bc4c3291b4a /gnu/packages/java.scm
parentc19a61bb3eef393cfadbe40e9ea9adf45e22a8be (diff)
downloadpatches-b8a680f778c021c91eaaaab4798bdcc7d417dce2.tar
patches-b8a680f778c021c91eaaaab4798bdcc7d417dce2.tar.gz
gnu: java-swt: Update to 4.6.
* gnu/packages/java.scm (java-swt): Update to 4.6.
Diffstat (limited to 'gnu/packages/java.scm')
-rw-r--r--gnu/packages/java.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index e1651938b9..753fb7726c 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -58,15 +58,15 @@
(define-public java-swt
(package
(name "java-swt")
- (version "4.5")
+ (version "4.6")
(source
;; The types of many variables and procedures differ in the sources
;; dependent on whether the target architecture is a 32-bit system or a
;; 64-bit system. Instead of patching the sources on demand in a build
;; phase we download either the 32-bit archive (which mostly uses "int"
;; types) or the 64-bit archive (which mostly uses "long" types).
- (let ((hash32 "03mhzraikcs4fsz7d3h5af9pw1bbcfd6dglsvbk2ciwimy9zj30q")
- (hash64 "1qq0pjll6030v4ml0hifcaaik7sx3fl7ghybfdw95vsvxafwp2ff")
+ (let ((hash32 "0jmx1h65wqxsyjzs64i2z6ryiynllxzm13cq90fky2qrzagcw1ir")
+ (hash64 "0wnd01xssdq9pgx5xqh5lfiy3dmk60dzzqdxzdzf883h13692lgy")
(file32 "x86")
(file64 "x86_64"))
(let-values (((hash file)
@@ -78,7 +78,7 @@
(uri (string-append
"http://ftp-stud.fht-esslingen.de/pub/Mirrors/"
"eclipse/eclipse/downloads/drops4/R-" version
- "-201506032000/swt-" version "-gtk-linux-" file ".zip"))
+ "-201606061100/swt-" version "-gtk-linux-" file ".zip"))
(sha256 (base32 hash))))))
(build-system ant-build-system)
(arguments