summaryrefslogtreecommitdiff
path: root/gnu/packages/java.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2020-05-16 15:59:39 +0200
committerJulien Lepiller <julien@lepiller.eu>2020-05-16 17:43:47 +0200
commit8ba990e69dcf471c3c24964cd8d7438c7fae427c (patch)
tree97139a812fe3d123f4cd5760fdd251a848e9cd96 /gnu/packages/java.scm
parent523cbfbd55fa73d0c31e2ac84008a18fffbd42f5 (diff)
downloadpatches-8ba990e69dcf471c3c24964cd8d7438c7fae427c.tar
patches-8ba990e69dcf471c3c24964cd8d7438c7fae427c.tar.gz
gnu: Add java-picocli.
gnu/packages/java.scm (java-picocli): New variable.
Diffstat (limited to 'gnu/packages/java.scm')
-rw-r--r--gnu/packages/java.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 071b97582d..fc1f7d157a 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -11943,3 +11943,28 @@ involving one or more shared resources having ACID (Atomicity, Consistency,
Isolation and Durability) properties.")
;; either gpl2 only with classpath exception or cddl.
(license (list license:gpl2 license:cddl1.0))))
+
+(define-public java-picocli
+ (package
+ (name "java-picocli")
+ (version "4.3.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/remkop/picocli")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "1sxp6rxjfgjd98ly14b3d15dvxkm5wg4g46w12jyhmr0kmkaca3c"))))
+ (build-system ant-build-system)
+ (arguments
+ `(#:jar-name "picocli.jar"
+ #:source-dir "src/main/java"
+ ;; Tests require missing dependencies (junitparams, system-rules)
+ #:tests? #f))
+ (home-page "https://picocli.info")
+ (synopsis "REPL for the JVM")
+ (description "Picocli is a framework for building command line applications
+for the JVM. It supports colors, autocompletion, subcommands, and more. Written
+in Java, usable from Groovy, Kotlin, Scala, etc.")
+ (license license:asl2.0)))