summaryrefslogtreecommitdiff
path: root/gnu/packages/java.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-09-07 16:25:47 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-09-07 16:25:47 +0200
commit6b7e09ae6bb78c9e2d07a259d93d9b4911234f4b (patch)
tree9844e4c4b5ad9c0e970aa5522e2f1fd1d658ceaa /gnu/packages/java.scm
parent64ad3989d7ebe85c73d2f49ac65eebdbfbee3bf3 (diff)
downloadpatches-6b7e09ae6bb78c9e2d07a259d93d9b4911234f4b.tar
patches-6b7e09ae6bb78c9e2d07a259d93d9b4911234f4b.tar.gz
gnu: icedtea-7: Patch code to enable build with newer glibc.
* gnu/packages/java.scm (icedtea-7)[arguments]: Add build phase "patch-bitrot". (icedtea-8)[arguments]: Remove phase "patch-bitrot".
Diffstat (limited to 'gnu/packages/java.scm')
-rw-r--r--gnu/packages/java.scm13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 51e738d864..def2c8d92d 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -1125,6 +1125,18 @@ bootstrapping purposes.")
((name . _) name))
inputs))))
#t)))
+ (add-after 'unpack 'patch-bitrot
+ (lambda _
+ (substitute* '("patches/boot/revert-6973616.patch"
+ "openjdk.src/jdk/make/common/shared/Defs-versions.gmk")
+ (("REQUIRED_FREETYPE_VERSION = 2.2.1")
+ "REQUIRED_FREETYPE_VERSION = 2.10.1"))
+ ;; As of attr 2.4.48 this header is no longer
+ ;; included. It is provided by the libc instead.
+ (substitute* '("configure"
+ "openjdk.src/jdk/src/solaris/native/sun/nio/fs/LinuxNativeDispatcher.c")
+ (("attr/xattr.h") "sys/xattr.h"))
+ #t))
(add-after 'unpack 'fix-x11-extension-include-path
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "openjdk.src/jdk/make/sun/awt/mawt.gmk"
@@ -1604,6 +1616,7 @@ IcedTea build harness.")
(delete 'patch-paths)
(delete 'set-additional-paths)
(delete 'patch-patches)
+ (delete 'patch-bitrot)
;; Prevent the keytool from recording the current time when
;; adding certificates at build time.
(add-after 'unpack 'patch-keystore