summaryrefslogtreecommitdiff
path: root/gnu/packages/java.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-11-13 11:47:43 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-11-13 12:49:22 +0200
commit3560a2cdaa5fdc56b0613bada93242f1360f2273 (patch)
tree5b3f3e6b37c7df2de1702ba39cc7737c17fc45b5 /gnu/packages/java.scm
parentca12352a3e8297fa015b099c7e395b6d7795aa6b (diff)
downloadpatches-3560a2cdaa5fdc56b0613bada93242f1360f2273.tar
patches-3560a2cdaa5fdc56b0613bada93242f1360f2273.tar.gz
gnu: java-eclipse-sisu-plexus: Don't use unstable tarball.
* gnu/packages/java.scm (java-eclipse-sisu-plexus)[source]: Use git-fetch and git-file-name.
Diffstat (limited to 'gnu/packages/java.scm')
-rw-r--r--gnu/packages/java.scm12
1 files changed, 7 insertions, 5 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index d9ea5526b8..c27e3c3c9d 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -9,7 +9,7 @@
;;; Copyright © 2017, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018, 2019 Gábor Boskovits <boskovits@gmail.com>
;;; Copyright © 2018 Chris Marusich <cmmarusich@gmail.com>
-;;; Copyright © 2018 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -10821,12 +10821,14 @@ OSGi Service Registry is a goal of this project.")
(name "java-eclipse-sisu-plexus")
(version "0.3.3")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/eclipse/sisu.plexus/"
- "archive/releases/" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/eclipse/sisu.plexus.git")
+ (commit (string-append "releases/" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0lbj7nxy5j0z71k407zbb82icfqh7midrfk0fb3fa3jzdjz0d9d9"))
+ "1nvxky49v4h724wkfn842n68gj70zinidn1cmhvbb31j1zp6wf8p"))
(modules '((guix build utils)))
(snippet
'(begin