summaryrefslogtreecommitdiff
path: root/gnu/packages/java.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-02-02 01:39:07 -0500
committerLeo Famulari <leo@famulari.name>2017-02-02 07:58:45 -0500
commit8f8d39b30c7c3d4a826af8673dae12def7404077 (patch)
tree6808fe9d53e01cfd44dec498ef2aef3d61648062 /gnu/packages/java.scm
parent3e27581887d76719eafc2c0a094664ab49efa988 (diff)
downloadpatches-8f8d39b30c7c3d4a826af8673dae12def7404077.tar
patches-8f8d39b30c7c3d4a826af8673dae12def7404077.tar.gz
gnu: icedtea-8: Update to 3.3.0 [security fixes].
Fixes CVE-2016-{2183,5546,5547,5548,5549,5552} and CVE-2017-{3231,3241,3252,3253,3260,3261,3272,3289}. * gnu/packages/java.scm (icedtea-8): Update to 3.3.0.
Diffstat (limited to 'gnu/packages/java.scm')
-rw-r--r--gnu/packages/java.scm24
1 files changed, 12 insertions, 12 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 5d53dffeec..92cbe2a02f 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -953,7 +953,7 @@ build process and its dependencies, whereas Make uses Makefile format.")
,@(package-inputs icedtea-6))))))
(define-public icedtea-8
- (let* ((version "3.2.0")
+ (let* ((version "3.3.0")
(drop (lambda (name hash)
(origin
(method url-fetch)
@@ -962,7 +962,7 @@ build process and its dependencies, whereas Make uses Makefile format.")
"/icedtea8/" version "/" name ".tar.xz"))
(sha256 (base32 hash))))))
(package (inherit icedtea-7)
- (version "3.2.0")
+ (version "3.3.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -970,7 +970,7 @@ build process and its dependencies, whereas Make uses Makefile format.")
version ".tar.xz"))
(sha256
(base32
- "104g2x5nhnqqvx6x29phx5vlrhlqy7qax83b9bqj1y619irrg8gj"))
+ "02vmxa6gc6gizcri1fy797qmmm9y77vgi7gy9pwkk4agcw4zyr5p"))
(modules '((guix build utils)))
(snippet
'(substitute* "Makefile.am"
@@ -1040,31 +1040,31 @@ build process and its dependencies, whereas Make uses Makefile format.")
`(("jdk" ,icedtea-7 "jdk")
("openjdk-src"
,(drop "openjdk"
- "093r3vlmbdx78w9s6d8lv4q65i0s9wq6an6i2g2d1zaf0js4043c"))
+ "0889n19w6rvpzxgmmk9hlgzdh9ya95qkc2ajgpnzr3h69g15nz48"))
("corba-drop"
,(drop "corba"
- "11r3h9snnj7m5bqnzc5ryd85igdv7xlwzs0zy24p9ii6gsc0f9lh"))
+ "0qcb72hhlsjgp6h9wd048qgyc88b7lfnxyc51xfyav0nhpfjnj8r"))
("jaxp-drop"
,(drop "jaxp"
- "1mp6ps15jk8v4nnvkmbvkk7g35icdjv7892q2a4f7b268yjcgmk1"))
+ "1vyc7dw10x5k45jmi348y8min6sg651ns12zzn30fjzhpfi36nds"))
("jaxws-drop"
,(drop "jaxws"
- "1fb5hikzzx8292nhdbp0snqn66fwnnv4rkjsk1zsjvrv4z5vk18j"))
+ "1dki6p39z1ms94cjvj5hd9q75q75g244c0xib82pma3q74jg6hx4"))
("jdk-drop"
,(drop "jdk"
- "1if9c5grp0km7pyn4mhfwi2ynh3ix20l1fqbfcy68sl2py7psmcj"))
+ "17czby3nylcglp7l3d90a4pz1izc1sslifv8hrmynm9hn4m9d3k8"))
("langtools-drop"
,(drop "langtools"
- "0kbah4h4pllk0gf50mp5f6720f5ci0ixqylccppb484hp95pblcl"))
+ "1h4azc21k58g9gn2y686wrvn9ahgac0ii7jhrrrmb5c1kjs0y2qv"))
("hotspot-drop"
,(drop "hotspot"
- "1gqz9qqsi61838dj08s01sa51zlnkvrk3hy721211dhnmkvlzmwx"))
+ "12bfgwhrjfhgj6a2dsysdwhirg0jx88pi44y7s8a1bdan1mp03r8"))
("nashorn-drop"
,(drop "nashorn"
- "04697l95g6y6n5dvy55k2040c6qp5hfz16qaibwzs594m3gzwwjz"))
+ "0bg9r16jffc64fhyczn4jpx7bkfw7w62prw65mh66vshqk4lbh0f"))
("shenandoah-drop"
,(drop "shenandoah"
- "0k6h7jk5i98jnld2ivy4bhydmkzrp25c3l6gwhvczvrhn7mlbnfx"))
+ "0abjlsvz669i06mlks28wnh11mm55y5613990pn5j7hfbw8a34q5"))
,@(fold alist-delete (package-native-inputs icedtea-7)
'("gcj" "openjdk-src" "corba-drop" "jaxp-drop" "jaxws-drop"
"jdk-drop" "langtools-drop" "hotspot-drop")))))))