summaryrefslogtreecommitdiff
path: root/gnu/packages/java.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-04-13 20:26:21 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-04-13 20:26:21 +0200
commitfc58cb5bd2f4a4fb9e910f553009fce8a60e56e9 (patch)
tree5a69fa6b63a7bfe7232cb98e949912c20775058d /gnu/packages/java.scm
parent9d89818a359dd0657e4eb7649b29ad4197b8db39 (diff)
parentbad368b0d794689f3a8a11b58f1ea4987938682e (diff)
downloadpatches-fc58cb5bd2f4a4fb9e910f553009fce8a60e56e9.tar
patches-fc58cb5bd2f4a4fb9e910f553009fce8a60e56e9.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/java.scm')
-rw-r--r--gnu/packages/java.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index c52140ba9e..e5e9d1bb9b 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -4422,7 +4422,7 @@ on the XPP3 API (XML Pull Parser).")))
(description "ASM is an all purpose Java bytecode manipulation and
analysis framework. It can be used to modify existing classes or dynamically
generate classes, directly in binary form. The provided common
-transformations and analysis algorithms allow to easily assemble custom
+transformations and analysis algorithms allow easily assembling custom
complex transformations and code analysis tools.")
(license license:bsd-3)))
@@ -7426,7 +7426,7 @@ import org.antlr.grammar.v2.ANTLRTreePrinter;"))
(home-page "https://github.com/barteo/microemu")
(synopsis "J2ME CLDC emulator")
(description "Microemulator is a Java 2 Micro Edition (J2ME) CLDC/MIDP
-Emulator. It allows to demonstrate MIDlet based applications in web browser
+Emulator. It demonstrates MIDlet based applications in web browser
applet and can be run as a standalone java application.")
(license (list license:asl2.0
;; or altenatively:
@@ -8821,7 +8821,7 @@ make data-binding work.")
("hamcrest" ,java-hamcrest-core)))
(home-page "https://hdrhistogram.github.io/HdrHistogram")
(synopsis "High dynamic range histogram")
- (description "Hdrhistogram allows to create histograms that support
+ (description "Hdrhistogram creates histograms that support
recording and analyzing sampled data value counts across a configurable integer
value range with configurable value precision within the range. Value precision
is expressed as the number of significant digits in the value recording, and
@@ -11651,7 +11651,7 @@ the application using Java to Lisp integration APIs.")
(description "JSON Processing (JSON-P) is a Java API to process (e.g.
parse, generate, transform and query) JSON messages. It produces and
consumes JSON text in a streaming fashion (similar to StAX API for XML)
-and allows to build a Java object model for JSON text using API classes
+and allows building a Java object model for JSON text using API classes
(similar to DOM API for XML).")
;; either gpl2 only with classpath exception, or epl2.0.
(license (list license:gpl2