summaryrefslogtreecommitdiff
path: root/gnu/packages/ipfs.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-03-23 23:16:55 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-03-23 23:16:55 +0100
commit8c14f7f8a7ab0722bf4c9f92fd28ae85514d564f (patch)
treeadc5d29e9c2dcda5befa0ca81f1af8df23294947 /gnu/packages/ipfs.scm
parent2f33a7321e5e37d37f57c229c8079cb4ffd10834 (diff)
parent3374e9207f5244c20402a3c5513fe562140fef47 (diff)
downloadpatches-8c14f7f8a7ab0722bf4c9f92fd28ae85514d564f.tar
patches-8c14f7f8a7ab0722bf4c9f92fd28ae85514d564f.tar.gz
Merge branch 'staging' into core-updates
Diffstat (limited to 'gnu/packages/ipfs.scm')
-rw-r--r--gnu/packages/ipfs.scm21
1 files changed, 13 insertions, 8 deletions
diff --git a/gnu/packages/ipfs.scm b/gnu/packages/ipfs.scm
index 9d00c9c981..6b8afd5f53 100644
--- a/gnu/packages/ipfs.scm
+++ b/gnu/packages/ipfs.scm
@@ -91,7 +91,9 @@ that are shared between @command{go-ipfs/commands} and its rewrite
("go-github-com-minio-sha256-simd" ,go-github-com-minio-sha256-simd)
("go-github-com-mr-tron-base58" ,go-github-com-mr-tron-base58)
("go-github-com-multiformats-go-multihash" ,go-github-com-multiformats-go-multihash)
- ("go-golang-org-x-crypto-union" ,(go-golang-org-x-crypto-union))
+ ("go-golang-org-x-crypto-blake2s" ,go-golang-org-x-crypto-blake2s)
+ ("go-golang-org-x-crypto-ed25519" ,go-golang-org-x-crypto-ed25519)
+ ("go-golang-org-x-crypto-sha3" ,go-golang-org-x-crypto-sha3)
("go-github-com-spaolacci-murmur3" ,go-github-com-spaolacci-murmur3)
("go-github-com-gxed-hashland-keccakpg" ,go-github-com-gxed-hashland-keccakpg)
("go-github-com-whyrusleeping-tar-utils" ,go-github-com-whyrusleeping-tar-utils)
@@ -137,14 +139,16 @@ that are shared between @command{go-ipfs/commands} and its rewrite
("go-github-com-multiformats-go-multihash" ,go-github-com-multiformats-go-multihash)
("go-github-com-spaolacci-murmur3" ,go-github-com-spaolacci-murmur3)
("go-github-com-whyrusleeping-tar-utils" ,go-github-com-whyrusleeping-tar-utils)
- ("go-golang-org-x-crypto-union" ,(go-golang-org-x-crypto-union))
("go-github-com-btcsuite-btcd-btcec" ,go-github-com-btcsuite-btcd-btcec)
("go-github-com-gogo-protobuf-proto" ,go-github-com-gogo-protobuf-proto)
("go-github-com-sabhiram-go-gitignore" ,go-github-com-sabhiram-go-gitignore)
("go-github-com-urfave-cli" ,go-github-com-urfave-cli)
("go-github-com-whyrusleeping-json-filter" ,go-github-com-whyrusleeping-json-filter)
("go-github-com-whyrusleeping-progmeter" ,go-github-com-whyrusleeping-progmeter)
- ("go-github-com-whyrusleeping-stump" ,go-github-com-whyrusleeping-stump)))
+ ("go-github-com-whyrusleeping-stump" ,go-github-com-whyrusleeping-stump)
+ ("go-golang-org-x-crypto-blake2s" ,go-golang-org-x-crypto-blake2s)
+ ("go-golang-org-x-crypto-ed25519" ,go-golang-org-x-crypto-ed25519)
+ ("go-golang-org-x-crypto-sha3" ,go-golang-org-x-crypto-sha3)))
(home-page "https://github.com/whyrusleeping/gx")
(synopsis "Package management tool using IPFS")
(description "@command{gx} is a packaging tool built around the
@@ -197,13 +201,15 @@ powerful and simple.")
("go-github-com-multiformats-go-multihash" ,go-github-com-multiformats-go-multihash)
("go-github-com-spaolacci-murmur3" ,go-github-com-spaolacci-murmur3)
("go-github-com-whyrusleeping-tar-utils" ,go-github-com-whyrusleeping-tar-utils)
- ("go-golang-org-x-crypto-union" ,(go-golang-org-x-crypto-union))
("go-github-com-btcsuite-btcd-btcec" ,go-github-com-btcsuite-btcd-btcec)
("go-github-com-gogo-protobuf-proto" ,go-github-com-gogo-protobuf-proto)
("go-github-com-sabhiram-go-gitignore" ,go-github-com-sabhiram-go-gitignore)
("go-github-com-urfave-cli" ,go-github-com-urfave-cli)
("go-github-com-whyrusleeping-progmeter" ,go-github-com-whyrusleeping-progmeter)
- ("go-github-com-whyrusleeping-stump" ,go-github-com-whyrusleeping-stump)))
+ ("go-github-com-whyrusleeping-stump" ,go-github-com-whyrusleeping-stump)
+ ("go-golang-org-x-crypto-blake2s" ,go-golang-org-x-crypto-blake2s)
+ ("go-golang-org-x-crypto-ed25519" ,go-golang-org-x-crypto-ed25519)
+ ("go-golang-org-x-crypto-sha3" ,go-golang-org-x-crypto-sha3)))
(home-page "https://github.com/whyrusleeping/gx-go")
(synopsis "Golang subtool for the @command{gx} package manager")
(description "A subtool for the @command{gx} package manager for packages
@@ -213,7 +219,7 @@ written in Go.")
(define-public go-ipfs
(package
(name "go-ipfs")
- (version "0.4.18")
+ (version "0.4.19")
(source
(origin
(method url-fetch/tarbomb)
@@ -221,8 +227,7 @@ written in Go.")
"https://dist.ipfs.io/go-ipfs/v" version
"/go-ipfs-source.tar.gz"))
(sha256
- (base32
- "19hfgbyn5sr1bw0cwm3gsjz0w3b3vh3mmkax1906raah30lavj1x"))
+ (base32 "0s04ap14p6hnipjm27nm5k8s28zv9k5g9mziyh3ibgwn7dzb1kpx"))
(file-name (string-append name "-" version "-source"))))
(build-system go-build-system)
(arguments