summaryrefslogtreecommitdiff
path: root/gnu/packages/indent.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2014-04-01 16:13:52 -0400
committerMark H Weaver <mhw@netris.org>2014-04-02 11:27:04 -0400
commit0ad2f2e6e9a56d5fc3ac580ace631afbddd63b37 (patch)
tree21e7f7f4d18f18c4b1a9fdaa04362f2bc6faffb4 /gnu/packages/indent.scm
parent27c68457d992895833a7b0a833679dc2efc9e188 (diff)
downloadpatches-0ad2f2e6e9a56d5fc3ac580ace631afbddd63b37.tar
patches-0ad2f2e6e9a56d5fc3ac580ace631afbddd63b37.tar.gz
gnu: indent: Install docs in share/doc.
* gnu/packages/indent.scm (indent): Add a phase to fix the docdir setting in doc/Makefile.in.
Diffstat (limited to 'gnu/packages/indent.scm')
-rw-r--r--gnu/packages/indent.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/indent.scm b/gnu/packages/indent.scm
index 78ceadf1be..7d7acba2dc 100644
--- a/gnu/packages/indent.scm
+++ b/gnu/packages/indent.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -35,6 +36,16 @@
(sha256 (base32
"0f9655vqdvfwbxvs1gpa7py8k1z71aqh8hp73f65vazwbfz436wa"))))
(build-system gnu-build-system)
+ (arguments
+ `(#:phases (alist-cons-after
+ 'unpack 'fix-docdir
+ (lambda _
+ ;; Although indent uses a modern autoconf in which docdir
+ ;; defaults to PREFIX/share/doc, the doc/Makefile.am
+ ;; overrides this to be in PREFIX/doc. Fix this.
+ (substitute* "doc/Makefile.in"
+ (("^docdir = .*$") "docdir = @docdir@\n")))
+ %standard-phases)))
(synopsis "Code reformatter")
(description
"Indent is a program that makes source code easier to read by