summaryrefslogtreecommitdiff
path: root/gnu/packages/imagemagick.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-05-28 17:56:47 -0400
committerLeo Famulari <leo@famulari.name>2017-05-30 13:33:15 -0400
commit6e82fb2c27725039203161d000fff9ff0dce8c97 (patch)
tree657645d3b531b4aa978ff38007835243e2038d10 /gnu/packages/imagemagick.scm
parented2b7cb2f9d4b596eb1386b08164db4f8ef2a5cd (diff)
downloadpatches-6e82fb2c27725039203161d000fff9ff0dce8c97.tar
patches-6e82fb2c27725039203161d000fff9ff0dce8c97.tar.gz
gnu: graphicsmagick: Remove bundled libraries from source checkout.
Fixes <https://bugs.gnu.org/27120>. * gnu/packages/imagemagick.scm (graphicsmagick)[source]: Add a snippet to delete bundled libraries. [version]: Bump the package revision counter to 3.
Diffstat (limited to 'gnu/packages/imagemagick.scm')
-rw-r--r--gnu/packages/imagemagick.scm16
1 files changed, 14 insertions, 2 deletions
diff --git a/gnu/packages/imagemagick.scm b/gnu/packages/imagemagick.scm
index bde3ebe402..5928b30e00 100644
--- a/gnu/packages/imagemagick.scm
+++ b/gnu/packages/imagemagick.scm
@@ -163,7 +163,7 @@ script.")
(define-public graphicsmagick
(let ((changeset "6156b4c2992d855ece6079653b3b93c3229fc4b8") ; fix CVE-2017-6335
- (revision "2"))
+ (revision "3"))
(package
(name "graphicsmagick")
(version (string-append "1.3.25-" revision "."
@@ -180,7 +180,19 @@ script.")
;; "/GraphicsMagick-" version ".tar.xz"))
(sha256
(base32
- "08yfsn8mrqkwpax43vv1crfr55rcf004wwpzsinr5c6m0asqr08b"))))
+ "08yfsn8mrqkwpax43vv1crfr55rcf004wwpzsinr5c6m0asqr08b"))
+ (modules '((guix build utils)))
+ (snippet
+ ;; Remove bundled software. This reduces the size of the built
+ ;; source checkout from 177 MiB to 49 MiB. This should not be
+ ;; necessary when using the GraphicsMagick release tarball,
+ ;; because these files are not distributed there.
+ '(for-each delete-file-recursively '("bzlib" "dcraw" "hp2xx"
+ "jbig" "jp2" "jpeg"
+ "lcms" "libxml" "png"
+ "ralcgm" "tiff" "ttf"
+ "webp" "wmf" "xlib"
+ "zlib")))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags